FEZ Panda II will not connect with USB


I just purchased a FEZ Panda II that appears to be defective and I would like an RMA so that I can return it for replacement. I’ve tried to connect to it in several ways. I’ve tried resetting the board, to no avail. All I get is a blinking red light.

Please send me an RMA.

Hi GKochanowski, welcome to the foums

Blinking red light is actually good… the sample app that is installed on it is running correctly !

If you still want to RMA then you need to head over to the GHI website and use the “contact us” details to get in touch with them.

But if you want to dig deeper, here’s the place to do it. Can you tell us what happens, what you see in Device Manager, whether Windows makes device insert/removal noises etc? Do you have any other Fez devices, or is this your first? If you have others, compare what you see in Device Mgr with them to see what is different. Then we can help navigate you along

I did that several days ago. After several days of emailing back and forth they told me to post the problem here. So here I am. I understand that the blinking red light indicates that the CPU is running, but I still can’t connect via USB.

I haven’t found anything in the documentation that has worked. I’ve tried connecting to it via several tools. I’ve tried reseting it. No luck. So I’m assuming that the USB is bad.

Just so you know, I’ve been working with the cobra boards for almost a year, so I understand how to connect to and use that product.

If they asked you to post here, they too think that something can be “saved”.

Please, tell us what you see in Device Manager. It seems to me that the cable you are using can supply power to the board but it can’t communicate to the OS, so do you have another cable that you can try? That’s a real quick test.

I see nothing. Whereas when I connect my cobras I see them no problem.

You have to give us a few clues…

What operating system and version of Visual studio?

What have you done and what happened or did not happen?

Have you tried an external power supply?

Windows 7, VS 2010 Ultimate, with and without power supply. The red light blinks. It does not connect.

OK with the bits of info you are sharing it seems there’s something obviously not connected correctly (it could be a dodgy solder joint on the USB connection). Time to email GHI back and point to this post then…

This is what I told them, but they told me to post on this forum. Now why would they do that?

Usually that has the effect that Gus sees the post and helps out and either resolves the issue or confirms RMA is the best way forward.

I’ve been in electronics for over 40 years. I’ve been doing micro development for at least 20 years. Gus should not assume that everyone is a newbie. As a result I’ve wasted almost a week. All they gotta do is look at my account to see that I’ve been buying product from them.

It’s been nice to meet ya’ll but I had hoped to get this issue resolved before a talk I am giving on July 5 to the local .NET user group on the micro .NET framework. I still have the cobra but I wanted to demo the FEZ Panda II kit.

This is a surprise. We usually reply within hours/minutes and we always ask new users to come directly to forum for help. 99% of typical cases are solved on teh forum quickly.

@ gkochanowsky - Sorry if this cause any confusion. We always start on the forum as ti is a huge knowledge base with many experts ready to help. If you tried the forum and wasn’t able to solve the problem, then you can easily send a link to GHI. When GHI engineers reviews your thread on forum, the can better determine if there is an issue or misuse.

So, let me try to help please. Correct me here, you have a Panda II that you just received. It has a blinking LED when you plug it in but windows doesn’t recognize it on USB? Do you see anything under “deceive manager” when you plug it in? Do you hear any sound from windows? Are you using a virtual machine?

When I plugged it in it tried to load the driver however it complained of an unknown device. I’ve installed all the GHI USB drivers I could find on your website.

We will try to get to the bottom of this quickly. We do not make assumptions, we just flow some steps to help us and you. Sometimes it is the PC, sometimes it is the software and other times it is a simple steps a users is missing :slight_smile: As you can imagine, we get many support questions daily and the only way to help everyone is by following certain steps. If you would have mentioned that you own other GHI boards things would have been easier since we know you have a good working PC.

So windows sees an unknown device but then when you use the SAME cable on the SAME USB port FEZ Cobra you have works just fine? Please double check before replying.

You were right Gus, the cable I was using with the Panda II was bad. Is a USB cable supposed to come with the kit. Mine didn’t have one so I rummaged around and found a USB cable (apparently defective) to use.

So do you agree with me that the forum is useful? :wink:

Enjoy your Panda :slight_smile:

Hold on. I’m trying to load the default Panda II test program and I’m getting the following error:

An exception occurred while attempting to launch the debugger: DebugPort.GetDeviceProcess() called with no argument.

Should I try to upgrade the unit?

I would restart the PC and use a new project. Since you been trying many things so far, something maybe locked up.

Can you tell me if a USB cable is supposed to come with the Panda II kit?