Main Site Documentation

FEZ Panda II - no contact via USB anymore


#1

Hello all,

I´ve a strange problem with my FEZ Panda II board; I tried to run the example code for the CAN as listed under http://wiki.tinyclr.com/index.php?title=CAN.
First I started with the unchanged code and attempted to receive messages, but I didn´t succeed. Then I tried the outcommented code for message transmission - the debugger provided an error message ("…inapprobiate access…" or something like that - I can´t reproduce it) at the point where the msgID is loaded. After some restarts it was not possible anymore to load any code. Also the .NET MFDeploy Tool (Version 4.2.0.0 dated 04.10.2011) and the USBizi Updater (package 4.1) did not get contact to the board (Ping & read firmware version) - this worked before.
In case of the MFDeploy tool I got the message “Error: No response from device”, but when I connect the board to the USB the setting “USBizi_USBizi” is automatically set in the tools configuration. So I guess, that somehow a communication takes place…

The update tool “hangs” after starting Ping / Firmware readout as long as the USB connection is established.

As HW-add-on I used a modified CAN Bus Shield from sparkfun (should be compatible to the FEZ Panda II board) - here I have disconnected Pin 1 (TxD) from the CAN Controller chip MSP2515 and I connected the CAN transceiver MSP2551 (RxD / TxD) directly to the board pins D4 (CAN1R) and D7 (CAN1T). Power supplied via USB, no other external HW than oscilloscope during signal measurements. Should work…

When the problem appeared with the first board, I was not shure, if I´ve damaged it by producing an ESD somehow. So I continued my trials with a second board, which also came into this “speechless” condition. In this case an ESD damage was definitly not possible. The output drivers of the related controller pins seem to be still working - they show changing levels during reset as expected.

So it seems to me, that I somehow damaged the bootloader / firmware with that application SW. Is this possible? What can I do for a re-activation of the boards? An exchange of the micro will help of course…
By the way, I´m a C # beginner…

Your feedback / advice is appreciated! Thanks in advance!

Best regards,

Armin


#2

I’d try running the USBizi Firmware update on your Panda II. Should be somewhere under GHIElectronics in your Start menu.


#3

Hi Armin, welcome to the forums.

Usually the first step in figuring out what state your application is in requires you to look in Device Manager, and listen for connection/disconnection sounds from Windows (I’m assuming you’re using Windows, tell us if not). This will show you whether you have a Debuggable .Net Micro device recognised or not.

Once we know if you have that we can look at the next step.

Typically this kind of issue might come from a very tight loop in your deployed application that gives no time back to the processor to the debug code, so it appears “unresponsive”. The typical approach is to go into the bootloader mode and clear the code, but lets confirm what you can see first !


#4

Hi FireyFate and Brett,

thanks for your replies!

@ FireyFate: No connection - no update possible :wink:

@ Brett: Yes, I use Windows (XP prof.) and I´ve disabled any sounds. I only see error messages when I try to connect the board to another USB port of my laptop - then the installation process states “Driver installation failed…”. How can I set the board into bootloader mode? The same procedure as described in the Updater? This doesn´t work…

Best regards,

Armin


#5

So you see exactly what in Device Manager? What Device can’t it install the driver for??

The driver is in the SDK directory, go into Dev Mgr and update the driver manually and see if that works (the path is something like this on Windows 7, unless you’re on x64 version of XP you’ll drop the x86 bit… C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers)

Tell us if that works or if the driver fails, it should tell us more when you’re in control of the install…


#6

Sorry, forgot to answer your bootloader question.

That’s a part of the firmware update process when you go into Tera Term and can see “BL” command prompt. Step through the process to update the firmware and tell us (or take screenshotsof ) what you see in Device Manager.


#7

Hi Brett,

so that´s what I did next following your advices:

  1. de-installation of the driver
  2. FEZ Panda II connected to USB - >“GHI .NET Micro Framework USB Debugging Interface detected”
  3. installation of the driver from the directory you mentioned (board still conncted)
    -> the installation process got stuck
    • disconnection of the board -> installation finished successfully
  4. re-connection of the board - “New HW found. It can be used now”
  5. Start of USBizi Updater Version 1.0.0
    • Ping -> program got stuck until disconnection of the board
    • Firmware version readout -> program got stuck until disconnection of the board
      => same behavior as observed before the driver de-installation.

With the third board I have (w/o that wheird application loaded) both operations / requests work fine!

Unfortunately our network prevents a download of Tera Term. I must search for a “bypass solution” …
Hope, the information above already helps!

Best regards,

Armin


#8

Simple tests please.

Open Device Manager.

With nothing connected, in device manager you should not see anything about a Debuggable .Net device. You should also NOT see any extra COM ports other than what your usual machine gives.

Plug in the Panda. It should recognise your device and show it as a Debuggable .Net device in device manager.

Unplug it again. Device manager should make it disappear.

Hold down the LDR button and then plug it in. You should see the GHI Boot Loader interface pop up as a COM port.

Please confirm all that works - that confirms that the device should be recognisable and updateable.

Now open USBizi Updater.

Select your firmware file, click UPDATE (because you’re already in bootloader mode, you don’t need to do steps 1,2,3)

Here’s my log from the USBizi Updater.exe on my Panda II:

– Log –
Connecting to device…
USBizi found at Port#: COM3
GHI Bootloader Version: 1.07

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erasing…
Erase successful!
Updating Firmware. Please wait…
Rebooting…
Disconnecting COM3
Rebooting…
Firmware updated sucessfully. Version number: 4.1.8.0
Updating Firmware is done!

Fingers crossed that’s what you get.


#9

Hi Brett,

ooups - where do I find the Device Manager? In Visual Studio I only found [project] Properties but not with fields as described by you… Is this a separate SW?
As I already mentioned - I´m a bloody beginner… sorry.

Thanks for you support!

Best regards,

Armin


#10

device manager in the control panel on your PC


#11

No separate Device Manager too… OK.

AND - Succeeded to re-flash the firmware! Other application SW runs properly!

=> both boards are OK again!

Thanks a lot to everybody - especially Brett - for your support!!!

Best regards,

Armin


#12

fantastic news ! Now you can get on and play !! :slight_smile: