Main Site Documentation

Fez Panda II - Firmware not recognized, First Use


#1

Hi All,

I just bought a Fez Panda II from an online retailer, which came in a bag with usb cord. I initially plugged the device and the LED blinks constantly. I tried connecting to the device using MFDeploy but the firmware is not recognized(USBizi). After reading some more and watching the tutorial, I figured I would need to install the firmware. I downloaded the Tera Term software as well as the 32bit driver executable. I tried setting up the boot loader mode, and was able to one time get windows to ask for a driver. It automatically loaded the NETMF driver but not the boot loader. Now everytime I try to use Tera Term I dont get the com port I need. If I use what available com 3 it just echoes my input. How can I fix this, or start over

Rob


#2

Welcome to the forum! A good place to start is the Beginner’s Guide, Getting Started section. The Panda II comes with a default LED blink app on it, so that is normal. The important part is to make sure the firmware you install on the Panda matches what you installed on your PC. THe best bet is to download the latest firmware (which may or may not be on your board already). Also, when you power up the Panda, you need to have the bootloader button depressed for a few seconds to get it ready to upload firmware. The USB drivers need to be installed prior to doing this.

There is a lot of information on this site under Downloads & Tutorials to get you going. Good luck and have fun.


#3

FEZ is much easier than you think but the excitement of getting new cool hardware and wanting to get it going may make you skip very important steps.

Everything you need is here http://www.tinyclr.com/support/ (By the way, this link should be on the little card that came with your FEZ)

Start at this section :slight_smile: “Start here to begin learning.”


#4

Dear Support,

Thank you for your quick response, I am still having issues with the unit. I tried connecting an external power supply to the unit as well as the usb cable, going through the boot loader sequence I was able to load the boot loader interface. It still does not recognize the port when connected. Once the boot loader driver was installed, I disconnected the board and reconnected and then I received a prompt to instlall the GHI debugger interface. I pointed towrds the GHI NETMF folder and ran through that installation. At the end it says the driver was installed but may not function (code 10). I am still unable to connect use tera, fezpanel or mfdeploy. Where do I go next, this has taken a bit of time.

Robert


#5

There is no ‘boot loader’ to install. This makes me think you are just missing having the correct drivers installed. Go to the downloads section and grab the drivers … heck here are the links:

32-bit
http://ghielectronics.com/downloads/NETMF/GHI%20NETMF%20USB%20Drivers%2032-Bit.zip

64-bit
http://ghielectronics.com/downloads/NETMF/GHI%20NETMF%20USB%20Drivers%2064-Bit.zip

Install the correct drivers for your computer and try again. When the FEZ is plugged in without the MODE button held down it will show up as a debugable NETMF device in device manager. When you plug it in with the MODE button held down it will show up as a COM port.


#6

Like I suggested before, follow the exact steps and when you are stuck tell us at what point you are stuck. At this point we have no idea where you are or what is going on so it is impossible to help you.

“please” read through this and follow exact steps and tell us where things are not going well http://wiki.tinyclr.com/index.php?title=Firmware_Update_USBizi

once firmware is updated, follow there EXACT steps too http://wiki.tinyclr.com/index.php?title=First_Project


#7

Dear Support,

Thank you again for your assitance. At this stage I am just trying to communicate on any level and am unsuccessful. I have followed all the steps, installed the 32 bit driver installer and it is still not recognizing USBizi in MFDeploy. So from that I go to lower level Tera, I have installed the driver and put into boot mode. I dont get the com port to communicate, so at this point I have no communication.

Robert


#8

Sorry this i not working for you but I still think you are not following the steps.

Let me step you through it:

  1. open your PC’s “device manager”
  2. connect your FEZ to your PC using the included USB cable. Connect it directly to the PC. Do not use any HUBs.
  3. What do you see added to “device manager”? It is going to be “NETMF Debug interface” or it will be a new COM port or the device manager will simply show an error in the device.

… awaiting you answer.


#9

I have tried this on two computers running XP. I open up device manager and observe any hardware changes while connecting device. It does not show any change on either computer when connected directly through USB. I am specifically looking at com port but I also don’t see any changes anywhere else.


#10

Is the LED blinking on your board? If not then was it blinking before at some point?

Do you have a different USB cable that you can try?


#11

The LED does blink when power is applied to the board. I haven’t tried another cable yet.


#12

The blinking LED is a test program loaded at manufacturing process so this means the board is functional and it is loaded with firmware and application. I would try a different cable before doing anything else, since you already tried a different PC.


#13

Problem fixed… The cable was not making a good connection. Sorry to waste time :’(


#14

theres no worries about wasting time, we love this place :wink:

Actually we’ve heard a few cable related issues so good to know yours was one too.


#15

So you were doing it right but the cable wad the problem. I am glad it is working now and look forward to help more in future.