Main Site Documentation

Fez Panda II and FEZ Touch


#1

A year or two back i bought a FEZ Panda II and FEZ Touch V1.0 for a project i was working on. I ended up never even using the stuff and they sat in a box for this hole time. I fished the stuff out the other day and i cant seem to get it too work.

I have very limited .net and programming experience i just want to figure out it the touch works before i get started. The problem is i can only get to turn the screen on and nothing else. I have tried the following:

https://www.ghielectronics.com/community/codeshare/entry/347 - LCD turns on blank white screen
https://www.ghielectronics.com/community/codeshare/entry/267 - LCD turns on blank white screen

The PANDA seems to be working fine, i have checked all the firmware and that seems correct. Can anyone offer up any suggestions?


#2

welcome Clo_Dawg

I’d first try with the “generic” driver, that is https://www.ghielectronics.com/community/codeshare/entry/216

The original fez touch page https://www.ghielectronics.com/catalog/product/262 has the links (although they don’t reflect the new locations so do take a little bit of sleuthing to find)

Next I’d suggest stepping into code and seeing at what point things like the white screen appears. Also, displays are notorious for using power, how are you powering your device? Final question, did you have the combination working when you originally bought them, ie do you know for sure they were working at that time?


#3

Hi Brett

I have tried that driver but i get the same result. The lcd just turns on with a white screen. Nothing happens when i touch it. Is this how these programs are suppose to work?? I cant test it on simulation because the compiler states “Fez panda not detected” or something like that.

I tried stepping through the example you shared a link too:
at this line:

backLight = new OutputCompare(lcdConfig.backLight, true, 2);

the LCD backlight turns on. Then nothing else happens.

I only used the panda through one or too tuts and put some led’s on and off. i never tried the touch. so too be honest it could be broken from the start for all i know?


#4

@ Clo_Dawg - Hi Clo_Dawg, the generic Fez Touch driver worked instantly for me, as well as the Fez Console. I really like this screen even if it has been discontinued.
You can try first with the provided samples as suggested by Brett. If it still doesn’t work, check the Fez Touch (pins, connections, etc). When connected to the screen should be gray first (or white).

Regards,

Famory


#5

@ Clo_Dawg - Are you connecting the Touch screen directly to the Panda, or through a cable? Also, what power source are you using? You may need an external power supply.


#6

@ Famory I guess the Touch is broken then. I don’t really know what you mean by check the pin and connections? The Screen is grey initially and when i run the code the backlight comes on making the screen “white”

@ jasdev I have tried with external power supply @ 6V, 7.5V, and 9V. The Touch is plugged directly into the panda2.

If you look at the image you can see how the screen is connected.


#7

@ Clo_Dawg - Hi Clo_Dwag,

Yes, really strange. I use to make it work with the USB cable connected to the laptop only.
One more question. Can you show us the back of the screen, specially the mode switch. It should be not be connected.

At least some of the pins are responding properly (VCC 1, GND 2, BackLight 6). You can continue checking some other pins like the touch screen ones. Have a look at
http://www.ghielectronics.com/downloads/FEZ/Component/Broch_FEZ_Touch.pdf.

One other suggestion, you picture shows that you are not using the screws to support the front of the screen. You should use them so that the connection will not be broken when you press on the screen.

Regards