Fez Panda Debug.Print not showing up in Output window

It’s entirely possible that I’m being a moron/total noob and missing something, but Debug.Print is not showing any output in VS2010’s Output window.

I’ve created a new Fez Panda Application, and added a single Debug.Print(“Hello World”) after the Thread.Sleep. I also changed the sleep length to 100 to speed up the blink (Panda came with the blinking LED app on it already). Hit F5, and the app get’s uploaded. I can add a break point, and the app is running as expected, but there is no “Hello World” in the Output window. Can anyone shed any light on this? Any help is appreciated.

A little more poking around, and it appears the output of Debug.Print shows up in the Immediate Window window as opposed to the Output window. Is this typical? I’m used to Console.Writeline statements appearing in the Output window.

I thought it goes in the output window!

Click tools then options.
Goto to debugging section. On the right uncheck the box that redirects all output window stuff to immediate window.

Yes it does, and then you select “Debug” from the drop down list.

@ bstag - Good to know. Thanks for pointing that out. I changed it, and I actually think I prefer the way it was working (throwing messages to the Immediate Window).

No problem. the only reason i know its location is set to goto immediate also.


In my case Debug output neither appears in Output window nor in Immediate window.

The solution to hit CTRL + F10 instead of F5 in VS to start the FEZ code.
This tells the debugger to run to the line with the cursor.

As Visual Studio is very buggy it may be necessary to press the Pause button (Break All) in the Debug Toolbar and then the start button (Continue) and suddenly all the missing Debug output appears at once out of Nirvana.


Elmue, was there any reason you dug up the old thread?

I would also say that my experience is that there are very few issues like you mention in VS2010. Do you have any add-ins loaded?