Main Site Documentation

FEZ Panda 2 - MFDeploy - ping not working


#1

Hi,
I am basically a software guy and new to the electronics world so please do not mind my simple questions and tell me things even it is very basic.

I bought FEZ Panda 2 few days back and started with the basic tutorials on the site such as
Digital Output - http://wiki.tinyclr.com/index.php?title=Digital_Outputs
Digital Input - http://wiki.tinyclr.com/index.php?title=Digital_Inputs_-_Buttons

The problem started when I tried the code from the tutorial
USB Debugging with Virtual COM Channel - http://wiki.tinyclr.com/index.php?title=USB_Client

I installed the drivers as per told in the article and then panda just stopped working. I changed the code to debug.Print only and tried to deploy again but VS2010 did not allow me. I searched on the forums and someone pointed that i should ping the device. At that time i was able to ping the device and check the device capabilities as well.

After that i tried to erase the program and then everything stopped working. Now even if i try to ping the device using MFDeploy, MFDeploy will get hanged. Same thing will happen if i try to do anything else using MFDeploy e.g. Device Capabilities.

Visual Studio Compile Error.:
An error has occurred: please check your hardware.

TinyCLR Error

An exception occurred while attempting to launch the debugger: DebugPort.GetDeviceProcess() called with no argument

Check the screenshot of MFDeploy in hanged state. Please suggest how to bring back the Panda 2 to its original state.
Thanks in advance


#2

I would skip this feature till you are very comfortable with your fez.

To fix, enter the loader bu holding the button. Then use E to erase all then you can load the firmware.


#3

Thanks for such a quick reply. But would you explain the steps little bit more or point to some page on wiki or other thread.

  1. What do you mean by “enter the loader bu”
  2. How to load the firmware

#4

“enter the loader BY” (not bu). Gus has been iPhoned again :slight_smile:

This just means to go back to the “loading firmware” process. http://wiki.tinyclr.com/index.php?title=Firmware_Update will get you there !