Main Site Documentation

FEZ Mini COM3 Problem


#1

Hi,

I’m trying to communicate to a telit gsm module over COM3 on my FEZ Mini. COM1 is used for Debugging, COM2 for talking to a GPS module (works fine). I had to install a level shifter that the communication with the Telit module works (3,3 <–> 2,8 V). When I’m talking over a TTL to USB Module to the Telit Module everything works fine. Now I just soldered the module to my COM3 but the Communication doesn’t work. I’m always getting back what I sent out.

I’m using this test code:

byte[] shdn = System.Text.UTF8Encoding.UTF8.GetBytes(“AT#SHDN\n\r”);
gsmPort.Write(shdn, 0, shdn.Length);
Thread.Sleep(100);
byte[] gsmbuf = new byte[10];
gsmPort.Read(gsmbuf, 0, 10);
Debug.Print(new String(System.Text.UTF8Encoding.UTF8.GetChars(gsmbuf)));

Normally the Module would respond with “OK” but I’m getting back “AT#SHDN\n\r”

I checked for solder bridges, changed RX/TX but nothing.
I’m really confused right now, thx for your responses.


#2

Can you try to read more data? Maybe echo is on (ATE0 will disable echo), and there is an OK following the “AT#SHDN\n\r”


#3

I tried it but there is no “OK” following,
normally if the “AT#SHDN” Command was sent, the module should turn off, but it stays on…

I suggest that the command is kind of looped back, the only problem could be the level converter, but it is sourced with 3,3V on the side of the FEZ Mini which should be perfect. And it works with the FTDI…


#4

check your connections to and from the level converter. Maybe you have shorted two pins on the converter?


#5

Checked them already and tried a different level converter:
1st one: http://www.sparkfun.com/products/8745
2nd one: http://www.watterott.com/de/8-channel-Bi-directional-Level-Converter-TXB0108

I’m now using the 2nd one, because it is bidirectional, but both worked fine with the FTDI board.


#6

you talked “loopback” which to me really implies that you have a solder bridge somewhere between RX and TX pins. Can you continuity test between them to see if they appear connected?