FEZ Hydra Driver Problems "Unknown Device"

Hi all,

first of all - thanks for the great work. I’ve got the same problem “semicolon” has had (http://www.tinyclr.com/forum/topic?id=7922) with the difference, that my problem isn’t solved yet :–)

Each time I connect my FEZ Hydra mainboard with my computer it says “USB Device Not Recognized”.
And I have installed almost every msi package/ driver/ etc. I could get.

I even tried it on several different systems ie. Windows 7 32bit, Windows 7 64bit, Windows XP.
I addes some pics with my mainboard, the modules I’ve bought and screenshots from the errors.

Thank you very much for your help!

If you look in “Devices & Printers”, what do you see in the bottom section? Have you tried using a powered USB hub?

Hi ianlee74,

in “Device & Printers” I can see under the section “Unspecified” an Unknown Device.
The device state is “Windows has stopped this device, because it has reported problems (code 43)”.

No, I haven’t tried a powered USB hub, but I’ve got an external current supply.
Thanks for your fast reply.

@ DesperateGuy - When you plug in the power / usb cable does the red power led on the Hydra come on and stay on bright, and does the green led come on briefly?

This is going to sound like a silly question but have you changed the USB cable? The reason I say that is that I had a USB cable that when I used it to power my spider I got the same issue.


@ Davef
I’ve got two hydras.
When I plug in the power in Hydra No1, the red power led stay on and the green led flashes up for a short time.

On Hydra No2 I erased the dataflash with the SD card. Now the red and the green led stay on.
However the green one doesn’t stay on very brightly. Maybe its because of the missing firmware.

@ HughB
it doesn’t sound silly :slight_smile: I read this also in another post and tried it with about three usb cables.
Unfortunately without success.

@ DesperateGuy - If you are sure all your cables are ok, then try this, if you are using 4.1 (4.2 maybe the same) look in the installation pack, under installation files you will find the USB driver msi files. Try re-installing the driver. Your number 1 hydra appears to be ok.

We never tested hydra with sytech power module. I can’t see why it wouldn’t work but just pointing out that it maybe the problem, a very very rare chance.

1 Like

@ Devef
Yes I am sure that all cables are ok. As you recommended me I tried different cables, operating systems, notebooks without any success.
Also I also tried to (re-)install the 4.1, 4.2 drivers again. Its really depressing :slight_smile:
Thanks for your help so far.

@ Gus
So you think it is might be the sytech power module? What can I do, so that its working?
Do I need a special driver?
Questions over questions :wink:

@ DesperateGuy - If you have a DVM you could measure the 3.3v / 5.0v on one of the Hydra connectors. Or you could ask around to try a DP / SP module. Otherwise you will need to buy an SP / DP module they would make good spares.

Hey Guys,

it works! I bought a DP module and everythings fine.
So I think there are some problems with the sytech power module driver or its power supply.

Thanks a lot!

Very strange! I would really like to know why it didn’t work.

@ DesperateGuy - It will be a connection or component failure, i don’t think a driver is required for the board . You could always send it back.