Main Site Documentation

FEZ Hydra Deploying Loader (TinyBooter) problem


#1

I’m following this instruction on how to update the Loader:
https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra
and I’ve come to the Deploying Loader section.(a screenshot of “Devices and Printers” in attachment"

Then I opened cmd as Admin and ran “UpdateFEZHydra.bat com5”, but keep getting the following result:

-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA CDC 2.10 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : com5
-I- argv 1 : at91sam9rl64-ek
-I- argv 2 : TinyBooterLoader.tcl
-E- Connection com5 not found
-E- Connection list :

I’ve tried to change the com number to some other number but didn’t work either.


#2

What version of Windows and is it on a USB 3 port?


#3

@ Aron - Hi Aron,
Windows 8 and it is a USB 3 port.

Edit: I assumed it’s a USB 2 port but turns out it’s actually 3. So does that make all the difference?


#4

@ lty20785 - It is a strong possibility. We have experienced issues while accessing things via the USB 3.0 ports. Try to use a 2.0 port and/or see if you can try on another PC that has Windows 7.


#5

@ Aron - Thanks for your follow-up!

I was able to update the loader with a USB 2.0 port, but I was still having trouble getting it into CLR mode. I tried 2 ways:

  1. “Reboot CLR” of the Fez Config tool, which didn’t quite work and it’s still in loader mode .
    although it says success
  2. I tried to update the firmware (despite it’s already up to date). Everything seems normal until it reboots, where fez config would hang there for a few minutes, and then display success. But after that, the hydra would stop working and even fez config can not communicate with it. I had to re-deploy the loader again.

#6

The firmware update would all go well, excepting hanging on “rebooting” for several minutes before showing the success message.

But after that, FEZ config cannot communicate with the hydra anymore and I have to re-apply the loader again.


#7

@ lty20785 - Try to use the MFDeploy tool provided by Microsoft’s Micro Framework SDK to update the firmware after deploying TinyBooter.


#8

You’re deploying the Ethernet firmware. You do have your Ethernet module connected to the correct socket, don’t you ? The Ethernet firmware does not work (ie a won’t start kind of failure) if you don’t have the Ethernet module connected correctly… perhaps try without the Ethernet firmware to see if that makes a difference to start?


#9

@ Brett - Yes that’s the problem. Thanks a lot!


#10

@ Aron - I saw you mentioned in a post more than a year ago that SSL is not supported on FEZ Hydra. Is it supported now?

Thanks


#11

The link https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra is not working anymore. Does anyone happened to know how to get to this page? Or any directions to the com application needed to install the update?


#12

Perhaps here ?
https://old.ghielectronics.com/docs/39/fez-hydra-developers-guide
https://old.ghielectronics.com/docs/127/firmware-update


#13

That is what I needed. Tnx!