Main Site Documentation

FEZ Hydra + CP7 - White Screen


#1

Hi All,

I’m stuck with this one.

I have the same issue with my original project, so I grabbed brand new set of modules: Hydra, usbClientDP and CP7.
Updated Hydra with 4.2.4.0.firmware (Feb. 18, 2013), as a test application I used a CP7TouchDemo (http://www.tinyclr.com/codeshare/entry/604).

All I get is a white screen, as soon as I connect this setup to the power. Have additional 12V 2A power supply connected to DP module.

Am I missing something?

Thanks in advance,
Ron


#2

I had same behavior with G120 and TE35, withe screen as soon as it’s plugged in but in my case flashing the firmware solved the problem. You are sure the firmware was updated successfully?

EDIT: how is the device detected in the device manager? Isnt the screen white in boot loader state to?


#3

Did you add CP7 in the gadgeteer designer? After you run the first time, the config will be loaded and the device will be rebooted.

Welcome to the community.


#4

So, I did a step back.
Uninstalled “GHI NETMF v4.2 and .NET Gadgeteer Package 2013-02-14” and installed “GHI NETMF v4.2 and .NET Gadgeteer Package (11-29-2012)”.

Updated firmware:
[em]-- Log –
Connecting… TinyCLR
Please wait while rebooting in TinyBooter mode…
TinyBooter Version: 4.2.4.0
Firmware Version: 4.2.4.0
Connecting to device…
Hydra found at Port#: COM5
Device will be updated automatically! DO NOT disconnect or turn off the device!
TinyBooter updated sucessfully. Version number: 4.2.3.2
Updating Firmware. Please wait…
Deploying C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\Firmware\Non Ethernet\Config.hex… successful!
Deploying C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\Firmware\Non Ethernet\Firmware.hex… successful!
Rebooting…
Firmware updated sucessfully. Version number: 4.2.3.2
Updating TinyBooter and Firmware is done!
[/em]

Rerun the CP7TouchDemo ad got my 2 buttons on the screen.

Actually the screen went black straight after [em]“TinyBooter updated sucessfully. Version number: 4.2.3.2”[/em]

So, I did get my screen working. But it is still not clear why it didn’t work with 4.2.4.0…


#5

Did you create a new project and copy the touch demo from codeshare, or did you just open your original project and try to deploy it? If the latter, VS keeps the references of the SDK version you’re using at the time you create the app, so you need to either remove all references and re-add the new ones, or create new project, copy over the code into this project, and then deploy.


#6

Hi Brett,

I understand what you are saying, I did open an original project, but I believe that this is nothing to do with the project or the way the project was built.
Anyway, I did a test.

I have 2 identical specimens A and B as seen in Picture Nr 1. Both updated to version 4.2.3.2 and both running the same very complicated test application: it shows a nice image on a screen and uses a timer to turn an onboard LED on and off, in other words keeps it busy.

using System;
using Microsoft.SPOT;
using Gadgeteer;
using GTM = Gadgeteer.Modules;
namespace SimpleCP7Test
{
    public class Program : Gadgeteer.Program
    {
        Gadgeteer.Modules.GHIElectronics.Display_CP7 display_CP7;
        bool ledOn = false;
        public static void Main()
        {
            Mainboard = new GHIElectronics.Gadgeteer.FEZHydra();
            Program program = new Program();
            program.doIt();
            program.Run(); // Starts Dispatcher
        }
        void doIt()
        {
            display_CP7 = new GTM.GHIElectronics.Display_CP7(10, 11, 12, 6);
            display_CP7.SimpleGraphics.DisplayImage(Resources.GetBitmap(Resources.BitmapResources.Image_800x480), 0, 0);
            Gadgeteer.Timer timer = new Gadgeteer.Timer(1000); // every second (1000ms)
            timer.Tick += new Gadgeteer.Timer.TickEventHandler(timer_Tick);
            timer.Start();
        }
        void timer_Tick(Gadgeteer.Timer timer)
        {
            ledOn = !ledOn;
            Mainboard.SetDebugLED(ledOn);
        }
    }
}

The Specimen B was updated to version 4.2.4.0 using another PC, created new project, used same program.cs same code. The result can be seen in Picture Nr 2. LEDs on both A and B are flashing.

Interesting moment is, that while flashing both specimens with 4.2.3.2, screens were white from [em]Hydra found at Port#:[/em] till [em]TinyBooter updated sucessfully.[/em], when they went black. But then I was updating specimen B with 4.2.4.0 it didn’t go back to black, stayed white.

Another thing, if I reset A (4.2.3.2), screen would flash white for a second, prints FEZ_Hydra and Build Date in a top left corner and starts with application. Specimen B (4.2.4.0) wouldn’t do that. Screen would darken for a second and then come back to white.

Thats the story…


#7

Hi Ron100,

We have noticed the same problem and are working on a fix for the issue. We will provide a fix for this issue as soon as possible.


#8

Hi Ron100,

Here is a temporary fix for the problem:


            Register PMC_PCER = new Register(0xFFFFFC10);
            Register PIOC_PER = new Register(0xFFFFF800);
            Register PIOC_OER = new Register(0xFFFFF810);
            Register PIOC_SODR = new Register(0xFFFFF830);
            Register PIOC_CODR = new Register(0xFFFFF834);

            PMC_PCER.SetBits(1 << 4);
            PIOC_PER.SetBits(1 << 7);
            PIOC_OER.SetBits(1 << 7);

            PIOC_SODR.SetBits(1 << 7);

This code sets the LCD Enable Pin high. We will be including a fix in the next firmware release.


#9

Thanks Aron for smashing that bug so quickly !


#10

Thanks guys for help and fixing the problem.


#11

@ Aron - I just had a chance to apply your fix. Thanks again.


#12

Hate to dig out an old topic, but I’ve got a white screen on a Fez+CP7. Where does this Register code go? I’ve added in GHI.Premium.Hardware and when I call the code I get a “System.NotSupportedException” error. I tried calling it right after Program.Mainboard = new GHIElectronics.Gadgeteer.FEZHydra(); and right after = new GTM.GHIElectronics.Display_CP7(10, 11, 12, 6); without any difference.


#13

SDK out tomorrow fixes this. I suggest you wait instead.


#14

Yah! Wasn’t sure how long it would be for the next release.


#15

Insiders have the link and they are trying it now.


#16

WOOT! 4/26 Beta fixes my CP7 showing-all-white issues! Touch screen works well too. Just need to find that other post I saw about the screen having odd flickering and see how that was resolved.