Fez Hydra - can't connect

I am using VS2012 and the latest SDK bits with Fez Hydra. Everything was working fine until about a week ago and now my Hydra won’t seem to connect. I am using a powered DP (http://ghielectronics.com/catalog/product/280) with a 12V 1.5A transformer so power shouldn’t be the issue.

In Device Manager, i see “Debuggable .NET Micro Famework Device” (attachment 1) but when i try to run debug in VS, it says “Looking for a device on transport ‘USB’” then just counts “Iteration 0, Iteration 1…” (attachment 2) for about 15 seconds then says “Error 1 Device not found or cannot be opened - USB:Gadgeteer” (attachment 3).

My primary PC is Windows 8 so I tried with another PC that was also working before (running Windows 7) and I get the same behavior. I am wondering if my Hydra is toast.

As a last resort, i tried to reflash the firmware. The Updater tells me it can’t connect then i get a COM not found error (attachment 4).

Any ideas here? Thanks in advance!

@ craigkitterman - I’m afraid you have to go SAM-BA_CDC to flash firmware (look in the GHI installed software OSHW), Read well documentation on the support area of the site, becouse you need to start Hydra booter in COM mode. Before SAM-BA can work, the Hydra must be present as “COMx - Gps device” under LPT-COM branch of device manager.

If SAM-BA can’t access COMx port, you may have hardware problem. I get crazy anytime with hydra update. Don’t use USB hub nor USB3 ports.
Very often a reboot of the pc is needed.
After the firmware is flashed, detach Hydra from PC. Then reboot Windows. Attach Hydra again and see if it can be updated with CLR firmware from GHI Tool.

1 Like

“coprocessor” is likely unrelated. Confirm that by checking that it doesn’t disappear when you disconnect your Hydra, and potentially even reboot your machine. That is definitely something I’d try to resolve on it’s own.

Can you please take a screen shot of MFDeploy when you select USB as the transport? That will tell us the USB device name. As @ Dobova says, going back to sam-ba may be necessary - was there anything you changed in your code that might have led to a situation that doesn’t give the debugging interface any cpu cycles ? (that’s sometimes a cause of this kind of inability to connect)

It can’t even connect (see attached). I have been trying to reach GHI to get an RMA. I have filled in the contact form twice - no response. I tried to call twice now - and the phone just rings and rings. Can someone from GHI please contact me?

@ craigkitterman

Do you have access to another PC that perhaps is running Windows 7 and try to reflash the board from that PC?

Hi Aron, yes I have tried my Windows 7 PC as well. I used to be able to deploy from both of these PCs, now the device is recognized by neither. I would like to exchange for a new hydra. Can you please advised on how to do that?

I highly doubt there is anything wrong with the hardware. It may have a corrupted firmware or you loaded the ethernet firmware. Force your device in tinybooter and reload the firmware. If no luck, get into samba and reload everything.

1 Like

@ Gus - I’m having the same issue.

Does the Firmware can be corrupted so easly???