Main Site Documentation

FEZ HYDRA and Seeed relays module issue


#1

When I connect a Seeed relays module to socket 14 of the Hydra, my Hydra doesn’t boot anymore.
Does anybody else has this issue with these relais?

I also posted this issue at seeedstudio.com forums, but after 8 days still no reply.
Does anybody has an alternative for these relais with the same specs?


#2

This is very strange. I just checked the schematics and I am not seeing any reason why this would happen!

We will check it later when we are at the office.


#3

I can’t reproduce this problem. What other modules do you have connected? What code? What do you have connected to the relay?


#4

i can reproduce it…

Hydra with latest firmware Feb19… and SeeedStudio Relay version 1.0

if i plug the relay to any Analog port it blocks the Hydra from booting… when i switch it with an LED the hydra works fine…

Cheers.
Jay.


#5

What do you mean by blocking the Hydra from booting? Does it go to TinyBooter or does it just lock up?


#6

Yes it locks at tinybooter…see attached snapshot with the relay plugged in to Socket 14…


#7

and when i remove the relay the hydra boots normal, and starts the Application…

see attached screenshot with the relay unplugged.


#8

one more thing.
if i power the Hydra using a 12VDC 4A adapter with the relay plugged in the screen goes white …
if i remove the relay, the screen looks normal and it boots normal…

So yes the Relay must have some serious issues…


#9

With the scenario from reply 5, can you see if the same thing happens if you put it on socket 13?


#10

when plugged in to socket 13 it booted, but when i hit reset the board restarted my screen went white and out no where RELAY3 turned on…

i also sometimes get the screen attached…
MFDEPLOY Can’t ping the Device when plugged to socket 13.
and the following code doesn’t execute when plugged in to socket 13.


       for (int i = 0; i < 100; i++)
            {
                PulseDebugLED();
                Thread.Sleep(50);
            }

When i remove the relay all work as normal…

when using the Power Adapter instead of USB the screen goes white and it doesn’t execute the above code…

When i plug it to socket 3, 4, using USB i get white screen… code never executes.
Socket 7, 8, 9 screen boots but no code execution…no MFDeploy ping response.

i hope this helps


#11

Thank you JayJay for your information. I will look into it on Monday as I do not have the module available at home here on the weekend. ;D


#12

It seems to me that it’s the combination of the relay + the display. I don’t have a display to test with but using just a relay on socket 14 and a joystick on 13 and running the following code, I have no problems. Probably too much current draw. Odd that it would only do this on socket #14 though. Another possibility is that it could be related to having something actually attached to the relay. Jay Jay, are you testing with just the relay module or with something attached?


using System.Threading;
using GT = Gadgeteer;
using GTM = Gadgeteer.Modules;
using Gadgeteer.Modules.GHIElectronics;

namespace HydraRelayModuleTest
{
    public partial class Program
    {
        // This method is run when the mainboard is powered up or reset.   
        void ProgramStarted()
        {

            joystick.JoystickPressed += new Joystick.JoystickEventHandler(joystick_JoystickPressed);
        }

        void joystick_JoystickPressed(Joystick sender, Joystick.JoystickState state)
        {
            var relayState = !relays.Relay1;
            relays.Relay1 = relayState;
            Thread.Sleep(1000);
            relays.Relay2 = relayState;
            Thread.Sleep(1000);
            relays.Relay3 = relayState;
            Thread.Sleep(1000);
            relays.Relay4 = relayState;
            Thread.Sleep(1000);
        }
    }
}


#13

removing the display didn’t help, the PulseDebugLED(); never ran…

No i do not have anything attached to the relay… never ever attached anything to these relay…

One More thing to note… i tried another Relay board that was causing issues in my Spider… and it didn’t block the Hydra… but this relay is defective…

So my Conclusion, i think this has to do with the Poor soldering of the Sockets on these relays (Cheap Generic Sockets)… which i have complained about when they were first released…

Rock the sockets of the relays… and watch weird stuff happening…

I’m still waiting on Seeed to fix the issue and send me replacements…

i think it is time for someone to design better relays… Latching relays would be perfect since they won’t need to draw power at all time…Daisy linked Latching relays would make it even better.

Jay…


#14

I think you’re right. Poor assembly seems to be common with the Seeed modules :frowning:

Yep, I’d like to see GHI produce this :wink:


#15

I have same issue with relays board on FEZ Hydra slot 13 and 14. No problem on 8 and 9. No problem on FEZ Spider.