Main Site Documentation

FEZ Hydra and FEZ Cobra II not working


#1

Hi,

I have bought a FEZ Hydra and after I couldn’t connect to my computer (thinking that I burned it due to connecting wrong the USB module) I bought another one but this one is not working either.

I also have FEZ cobra II and two G120 modules, but all are experiencing the same issue.

The problem is when I connect them to my computer using USB, they appear on devices and printers, but a minute later they disappear, then appear again and go off again and the cycle is repeated all the time.

I tried with a USB power hub, even bought another computer thinking that something is wrong with my USB in my computer, but still get the same problem.

The thing is that my Netduinos and my Arduinos work without any issue.

Please help.

Fitim


#2

Is it possible for you to open Device Manager and capture a screenshot when the device is present? Perhaps you might need to capture video from your phone too, to show the behaviour.


#3

Sounds like board keeps resetting itself. You are not using any conductive materials to place you board on, by any chance?


#4

Hi and sorry for the delayed response.

@ Architect - no the board is on top of a wooden desk.

@ Brett - I have attached the screen (device manager.jpg)

Even when using FEZ Config application, the minute i click on “Ping” or “Device Version” buttons I get a dialog saying that the device is not connected or is not responding (attaching the screenshot as well)

Thanks

Fitim


#5

So I see you have the GHI debug driver loaded correctly and it’s working fine. The unknown device, if you disconnect the Fez I expect that device will still stay there.

Can you please watch Device Manager closely, and see what happens when you just leave the Fez connected. You earlier stated it disconnects and reboots. I want to know what driver shows as disappearing and reappearing - but I don’t want you to do anything, just leave the device connected.

Then, if it works consistently and doesn’t disconnect, I would like you to use MFDeploy to check firmware versions and tinybooter versions. Open MFDeploy, use Device Capabilities option from Target menu. Report back what the version info says.


#6

I would also examine the power module. That is the other common part of your setup.


#7

Have you tried a different USB cable?


#8

Hi,

I have tried different USB cable.

I have USB Clinet SP and USB Client DP. The same issue with both of the power modules.

If I leave FEZ connected and don’t use anything (Visual Studio, FEZ config) then it stays connected.

When I try to get Device Capabilities using FEZ config I get the same error dialog saying “Failure - Device is not connected or not responding” (attaching screenshot)

MFDeploy is not recognising the board at all (screenshot)

Thanks

Fitim


#9

This certainly is strange.

Andre, I thought that the last device manager picture implied WinUSB driver? Fitim can you look at the detail of that driver and see what you can see?

One of the things I’d ask is do you have access to another PC that you can use for testing, or someone you know already has similar Fez devices set up and working - thinking that there’s something specifically wrong in your setup that is hard to identify, and testing this would mean we can eliminate that.

Have you tried booting the devices into bootloader mode and seeing if you can manually erase and re-upload the firmware?


#10

I think so too. GHI’s driver has full name for the framework in the description.


#11

Hi Brett,

I have another machine (Windows 2008 Server) and I am experiencing exactly the same thing (installing the same software from your site on both machines)

The device driver used is ghi_netmf_winusb.inf which is located at :

C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb

The weird thing is that I have 2 FEZ Hydra modules, 1 FEZ Cobra II, and 2 G120 modules and all are experiencing the same.

I wouldn’t know how boot the devices into bootloader mode. If you could show me how I would be grateful.

Regards

Fitim


#12

https://www.ghielectronics.com/docs
https://www.ghielectronics.com/docs/177/loader-tinybooter


#13

Brett you are a Genius !!!

Erasing my boards manually and re-uploading the firmware did the trick for all my boards. Now I can connect to all of them and I can deploy stuff from Visual Studio.

Than you very much !!!

Fitim


#14

yay that’s awesome ! Now get on and make awesome projects !!! :slight_smile:


#15

I am having the exact same issues, how exactly did you manually reset your boards?


#16

Boot your board with grounded loader pin/Pushed loader button (LDR…)
Then upload tiny booter and Firmware with FEZConfig.


#17

@ Reinhard I am a complete retard at electronics and circuit boards etc. I am a c# developer by trade.

What exactly is “grounded loader pin/Pushed loader button (LDR…)” ?

and how can I upload anything to a device that refuses to connect?


#18

hi Squirrel,

The grounded statement is just a way to go into manual bootloader mode. It’s a different mode of the processor and will load a different driver, and you load the fundamental software from that point.

Do you have a joystick or button module? An Extender or Breakout board? Those can be used to “automatically” do what you need. Basically, you need to connect the “loader” pin on that board (it varies) to the ground pin when you apply power, which then invokes the bootloader

You don’t say what board you have, so I can’t point you to the direct instructions, but you can use the following general pointers to start.

https://www.ghielectronics.com/docs/237/update-preparation-loader-tinybooter-and-firmware-tinyclr

https://www.ghielectronics.com/docs/177/loader-tinybooter

Let us know what device you have and what you have access to and we’ll find a way to help


#19

@ Brett

Thanks for the reply. I do apologize to anyone if I seemed blunt I my previous responses, its the boards and useless error messages that I am getting frustrated with.

I have a FEZ Hydra with a USB client module (red one) with an extender module and a light sensor module.

I was hoping to setup a simple test with a servo whereby I could detect light and the servo would then move in the direction of the light.

I understand that connecting the servo to the extender module does require a little bit of fiddling around and not as simple as plug in, but I thought “it couldn’t be that hard” :slight_smile:


#20

you don’t need to apologise, it’s all ok. Lets use your own thread to help you out here, see you over there in a second !