FEZ Feather - in PC device manager it is as Other device

Hello all,

I received FEZ Feather and it looks nice. However, at this moment, I cannot do anything with it…
I tried several USB cables and different USB ports, but it is still identified as “Other device / SC20100” or when I turn it on with “LDR” button pressed it is then “Other device / GHI Bootloader Interface”. I have Win 7 64 bit.


I tried “TiyCLR Config” software and it looks like it needs Feather to be defined in device manager as COM port. But it is not in my case.

I also tried VS 2019, however in “Project properties / TinyCLR OS” in “Deployment” I have “USB” selected, but in Device, there is just “”.

Are there some kind of drivers that I need to install and I just missed them?

I am looking for any tips. I enjoyed my days fooling around Panda II back in the past, so I wanted to tried something new.


Win7! Time to upgrade my friend. If you try the driver here does the loader work? GHI Electronics Bootloader

Welcome to the community

Thank you. I missed those files at the bottom of the page. Now it is identified as COM23. Loader is version 2.1.3.

However, when “application” is running (fast blue LED blinking - i guess some kind of default application?), it is still identified as “SC20100” in “Other devices”. And VS 2019 still cannot load an application.

I tried to plug FF into my mini-notebook with Win10 Home and in it’s device manager it is in regular USB devices as “SC20100” as well. So I guess, in Win 10 everything is OK.

Is there something I could do in Win 7 to make this work as well? Any “SC20100” drivers for Win 7? Or some tip to make it “visible” for VS 2019?

We have a driver… Looking for it

I could not find online. We will have to check on Monday when we are back at the office.
Please note that Win7 is not officially supported but we are going the extra mile trying to help.

@Greg_Norris can we add to downloads please if we have it?

Thank you in advance. I appreciate it a lot, really.

Hello, please, were you or Mr. Norris sucessfull with finding Win 7 drivers?

So I tried the only win7 machine we have here that we keep for testing and TinyCLR 2.0 worked! Then I uninstalled the driver from win7 and now I am seeing the same results as you do!

What does this mean? It means we do have a driver somewhere as the win7 machine was working fine till I removed the driver. The question now is, where is this driver? :slight_smile:

1 Like

Hello, I know, right now I am just a big pain in the A, but any luck finding the driver?

No but we plan on making one. We are busy releasing preview 2 this week.

Here it is http://files.ghielectronics.com/downloads/TinyCLR/Drivers/GHI%20TinyCLR%20WinUsb%20Win7.zip

this will be added to the downloads page

Thank you very, very much. Now it is playtime. (but my wife will not like you that much during following holidays :slight_smile: )