Main Site Documentation

Fez Domino Debug Interface


#1

Hi

I am having trouble changing the board from USB to Serial to allow me to use USB Client CDC. I have tried soldering a jumper wire in the MODE pin to set it low, but after this it could not find the device at all.

Thanks


#2

from @ realiser, http://tinyclr.com/forum/2/6226/ . This was for a Panda2

[quote]Be very careful with that MODE pin… If you have it bridged but no debugger connected to COM1, tie COM1’s RX pin with a resistor to ground otherwise it will hang on boot-up.
[/quote]


#3

Note that with my Panda II, I haven’t seen this behavior, and I’ve tried it several times. I use this technique to trigger my sprinkler controller into mass storage mode (if it boots and MODE is bridged, then it starts up as a mass storage device instead of a sprinkler controller).

I’ve never done any debugging on any serial ports.


#4

I first had it on my Domino and then recently on the Panda. It has something to do with the Rx pin floating. If it floats in a “good” direction then everything will work fine, but if it happens to float the wrong way one fine day your trouble will start.

I never figured out exactly what is happening but I think it is probably the debugger looking for activity on bootup and if it sees noise on the floating pin it probably tries to interpret it and doesn’t recover gracefully.

Tying down active but unused input pins is a good idea anyway. Less to go wrong.