Main Site Documentation

FEZ Domino - A Known Problem, but, Unknown Solution?


#1

Hi,

I am having the problem mentioned in topic:
http://www.tinyclr.com/forum/1/1562/

Yes, my system is win7 Home Edition & Turkish (But genuine OEM edition). Since it is not Ultimate I cannot change system language. But my VS2010 Ultimate is English and genuine (Not cracked or anything illegal).

I had an old FEZ Domino and took it out from my dusty shelves. Following the beginners guide downloaded the latest SDK 4.1, updated the firmware (4.1.8) using auto updater (running in administrative mode), using MFDpeloy tool checked everyting :slight_smile: Started using the FEZ domino but I had the problem mentioned in the above topic (http://www.tinyclr.com/forum/1/1562/). In other words, I cannot use “FEZDomino_GHIElectronics.NETMF.FEZ” dll… But the hw & sw runs without it… I really want to make use of FEZ domino specific libraries that makes the life far easier…

I would like to hear any solutions or suggestions you might have for me :smiley:

PS: I cannot change win7 language since it is home edition…

For further info I am giving details:

My Firmware Update;
Connecting to device…
USBizi found at Port#: COM10
GHI Bootloader Version: 1.07

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erasing…
Erase successful!
Updating Firmware. Please wait…
Rebooting…
Disconnecting COM10
Rebooting…
Firmware updated sucessfully. Version number: 4.1.8.0
Updating Firmware is done!

My MFDeploy Device Capabilities;
Pinging… TinyCLR
Pinging… TinyCLR
Pinging… TinyCLR
HalSystemInfo.halVersion:
HalSystemInfo.halVendorInfo:
HalSystemInfo.oemCode: 0
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 0
HalSystemInfo.moduleSerialNumber:
HalSystemInfo.systemSerialNumber:
ClrInfo.clrVersion: 4.1.2821.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.1.2821.0
SolutionReleaseInfo.solutionVersion: 4.1.8.0
SolutionReleaseInfo.solutionVendorInfo: GHI Electronics, LLC
SoftwareVersion.BuildDate: Dec 22 2011
SoftwareVersion.CompilerVersion: 410561
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 0
LCD.Height: 0
LCD.BitsPerPixel: 0
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

My (Not actually mine from tutorial :slight_smile: ) VS2010 program and configurations;

using System;
using Microsoft.SPOT;
using System.Threading;
using Microsoft.SPOT.Hardware;
using GHIElectronics.NETMF.FEZ;

namespace MFConsoleApplication1
{
    public class Program
    {
        public static void Main()
        {
            OutputPort LED;
            //LED = new OutputPort((Cpu.Pin)4, true);	//THAT WORKS 
            LED = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.LED, true); //THAT DOESNT WORK                                                                              
            while (true)
            {
                LED.Write(!LED.Read());
                Thread.Sleep(500);
            }
        }
    }
}

And my .dll references are;
FEZDomino_GHIElectronics.NETMF.FEZ (version: 4.1.2821.0 ; runtime version: v4.0.30319)
Microsoft.SPOT.Hardware
Microsoft.SPOT.Native
mscorlib


#2

You need to change your “system locale” not the language on Visual Studio.


#3

You are right! :think: I had misunderstood the “System Locale”. Now I changed “System Locale” to English(American)… But, unfortunately, it did not work(Yes, I tried also after restarting pc :slight_smile: ) :snooty:. “System Locale” should be alright now…

I also tried installing Visual C# 2010 Express Edition (without uninstalling VS2010 Ult.)… Uninstall, reinstal, repair… tired all a few times but VC#2010 Epx.Ed. did not work either. :snooty:

I would like to share also problem I had with VC#2010Exp.Ed. (They may help). In VC#2010ED some new projects I had in VS2010Ult. are not available such as “console application”, “class library” and “Device Emulator”. You can see the attached image. Also in VC#2010 I could not start even the available project types. Also you can see the error I got in the image I attached… I could not understand why I get this error.

Also I would like to note that I even reinstalled, repaired .NET MF SDK 4.1 after installing VC#2010Exp.Ed.

Even in VS2010, FEZDomino Application, given example program does not deploy… It is obviously the problem that I mentioned at first post… Just cannot find the solution :-[ :wall:


#4

By the way, I am not sure whether it will help but here is the output screen of VS2010;

------ Build started: Project: FEZ Domino Application1, Configuration: Debug Any CPU ------
FEZ Domino Application1 -> C:\Users\dell\Desktop\NETMFTrialProgram2\FEZ Domino Application1\FEZ Domino Application1\bin\Debug\FEZ Domino Application.exe
------ Deploy started: Project: FEZ Domino Application1, Configuration: Debug Any CPU ------
An error has occurred: please check your hardware.
Object reference not set to an instance of an object.
Source: Microsoft.SPOT.Debugger.CorDebug
Stack :
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.Deploy() in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\VsProjectFlavorCfg.cs:line 893
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.<Microsoft.VisualStudio.Shell.Interop.IVsDeployableProjectCfg.StartDeploy>b__0() in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\VsProjectFlavorCfg.cs:line 634
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

PS: If any more info needed, I will try to supply it :slight_smile:


#5

tart fresh and do not us ANYTHING from what you had before.

uninstall everything
set your locale to English
install VS
install NETMF 4.1
install GHI package

make NEW project and try to deploy.

We have a distributor in Turkey. Maybe he can help you out better?


#6

Well, I did all you said in the same order. Nothing changed…

Tried installing MFSDK and GHI tool (the same files I used for my notebook) to my desktop (VS2010 pro was already installed)… It worked on the desktop.

Than uninstalled everything from my notebook and istalled back (this time VS2010 Pro the version I used in the desktop) in the advised order… Nothing changed, still I have the same problem on my notebook(which is a nice one).

I also contacted to the distributors too… GHI dll’s seems to be problematic in win7 64-bit Home Edition Turkish OSs. Because I can still make it work with Microsoft dll’s, but, of course learning pin numbers etc. makes the life harder. Even changing the “system locale” and uninstall-installing everything seems to be not working. At least anybody I contacted so far could not solve the problem and changed OS to win7 Ultimate English…

Anyway I can continue my work now although it makes me chained to the office…

Thanks for the immediate support…