Main Site Documentation

FEZ Connect issue


#1

Hello,

I’m working with the “FEZ Connect Shield” and have a big Problem with it.

Every time I disconnect the power supply of my FEZ Panda II (USB or external supply) my deployed application does not start after I reconnect the power supply.

In this case I need to remove the shield from the Panda II. Then the application starts normally. Now I can reconnect the shield.

The last line which the debugger shows when I try to deploy a new application after the power supply has been disconnected is:

‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\FEZPanda_II_GHIElectronics.NETMF.FEZ.dll’

Thanks for your feedback.
Christian


#2

What power supply are you using ? From what you said, it could be too weak ???


#3

No matter what, the FEZ should start right up into user code as soon as you apply power (unless it’s in bootloader mode or something), so what you are describing sounds a lot like your current source cannot supply enough amperage to power the FEZ.


#4

Sounds like a power supply issue to me as well. I ran into this problem with the little 9 volt switching power supplies that are sold by adafruit, sparkfun etc. They were supposed to deliver 660 ma at 9 volts but they would not run the arduino or Fez with an sd card. A 500 ma transformer type wart drove them fine.

Apparently some of them are good and some notso. Measure what the 3.3 and 5v leads say plugged in to the usb port and plugged only into the power supply. That will tell you for sure.


#5

9v is way too much, prefer a 6 to 7v DC switched supply, 1A is perfect. With a 9v power supply and all the current the the wiz5100 is drawing, the panda/domino 3V3 regulator will fry.

I bought several of these 6,5v 2A 5$ adapters and they work great:
http://www.robotshop.com/ca/6-5v-2a-wall-adaptor-2.html


#6

I realize that 9V is too high, but that is what is being sold commonly to drive these things. I use Jensen 7.5v 1700ma switching supplies. I will order the ones that you suggest from Robotshop.ca with my next order. Which will be when they get some Fez Touch back in stock.


#7

Nicolas3, further to your power supply comments. The 3.3v regulator is fed by the 5v regulator, not vin, so the chances of hurting it are slim unless you take out the 5v reg first. The Fez Panda schematic shows the 5v regulator fed by 12 v.

The Wiz 5100 shows a absolute max input current of 5 ma.

Having said that, I still like a clean, stable input voltage at least 1.2 volts above the first regulator. The 6.5v volt supplies you suggested should do that. The Jensens I use now also meet that criteria.


#8

The regulators have built in thermal protection


#9

And that is a good thing considering the likelihood of a ‘breadboard related incident’. ;D


#10

[quote]Every time I disconnect the power supply of my FEZ Panda II (USB or external supply) my deployed application does not start after I reconnect the power supply.

In this case I need to remove the shield from the Panda II. Then the application starts normally. Now I can reconnect the shield.[/quote]

It seems that you are not setting the reset signal of FEZ Connect in the code. I am saying that because you mentioned that it works after you physically remove the shield and put it back in.

I strongly think it is a code problem, not power problem. Because you said it works (with the same power supply) after connecting the shield back.


#11

Joe;

Since you probably know the connect shield better than any of us, do you have a definitive number on how long the 2.2F supercap will keep the rtc ticking? I am currently using 2 alkalines which will go indefinitely but if the supercap will work I would use it. We have had numerous outages here in the last few weeks of thunderstorms, one which lasted two days.

I guess this should have been a new thread.


#12

Just to bounce, for me the current usage of the fez connect seem to be well well over 5ma ! Just put your finger on the chip you will know what I mean. Per the datasheet ( http://www.sparkfun.com/datasheets/DevTools/Arduino/W5100_Datasheet_v1_1_6.pdf page 63) the average power usage is 138-183mA depending on the speed (10 or 100). I saw micro-peaks much higher when opening a socket for a few uS.

When I started testing the FEZ boards, I used 9V DC power too. It was working very well untill I connected the wiznet5100 daughter boards : one of the regulators on my domino was getting very, very hot :-[

Look at the FEZ connect documentation : http://www.ghielectronics.com/downloads/FEZ/Shield/Broch_FEZ_Connect.pdf bottom of page 2 :

[quote]Important Note: Due to the high current need for Ethernet (about 135mA), the voltage used to power FEZ
should be 6V to 7.5V. A higher voltage may overheat the regulators.[/quote]


#13

I completely agree that anything beyond the 1.2 forward voltage required (above the reg output V) is a waste. But if you look at the power supplies offered by sparkfun or adafruit (fez dosen’t seem to offer one) They are all 9 or 12 volts. My favorite supplier, Robotshop.ca, is one of the few to offer alternatives and I suspect that most people end up at 9 or 12.

The ethernet shield offered by Sparkfun has an sd card reader (which panda II doesn’t need, hooray!) and they have large current needs. The Fez Connect has a 2.2F Supercap which would have a large inrush current from a discharged state. The 5ma came from the WIZ5100 datasheet max input current but it doesn’t state whether that is per socket, or anything else for that matter.

The second generation sparkfun shields has a new feature to deal with power off resets but I see the Fez unit still has a reset. I don’t have one, but the symptoms that Christian had were identical to what I dealt with with the Adafruit SD shield. Tethered to the computer it worked fine, but on the cheapie switching supply the 5v was pulled down to 4.6 and the 3.3 to 3.1 and the thing would not function until I switched power supplies.

Anywho, the point I was trying to make was that you are unlikely to hurt the 3.3 reg as you suggested.


#14

I am not certain but it should be couple days.


#15

First of all, thank you for all quick replies…

Now the Connect Shield works fine. The problem was that I was using a wrong reset pin (DI9 instead of DI7) :-[