Main Site Documentation

FEZ Cobra not working


#1

Hello,

We have been using the FEZ Cobra for the last couple of weeks. We were in the middle of a debugging session and visual studio lost the connection to the kit and reported an error saying “USB Debugging failiure” or something like that.

Now we can not boot in to the EMX firmware.
We can succesfully boot into GHI Boot Loader and Tiny booter, but we can not boot into the EMX Firmware.

After we deploy the firmware, the kit restarts and can not be accessed or recognized by the PC.
if we then restart the kit, it boots into GHI Boot loader again.

Is there anything we can do?

Thank you


#2

When i press “R” in bootloader it returns “Bad Firmware”


#3

I’d go back through the entire update process - erase all, reapply the tinybooter and then GHI firmware.


#4

Hello Brett

Thanks for your reply.

We have already tried that, after we apply the GHI firmware we lose connection to the kit and can not ping it.

Here is the log from the NetMF deployment tool:

Pinging… TinyBooter
Bootloader build info: GHI Electronics, LLC
Chk signature
Signature PASS
Chk signature
Signature PASS
Chk signature
Signature PASS
*** nXIP Program found at 0x00004000

TinyCLR (Build 4.1.2821.Pinging… Error: No response from device

If we restart the kit again and go in to bootloader mode and check the firmware version we get:

“Bad Firmware”

Thank you


#5

Did you followed the steps in http://www.youtube.com/watch?v=Y4Va_tPqqpg to the LETTER?


#6

Pleasanter erase all. That is the E command in GHI loader


#7

Hello again

We did follow every step on that video to the letter. Including the erasing, we still however end at the same spot after we upload the 3 firmware files. The kit restarts and we lose connection to it. Tried on different PC’s aswell.


#8

Contact GHI directly for fix/replacement with a link to this post.