FEZ Cobra not responding

I have an issue very similar to this

I was in the process of doing a firmware update when the FEZ cobra stopped responding. Everytime, If I now connect it to a PC the screen is completely white and no connectivity is available. I have tried to power it from a seperate power supply and I have also tried different USB hubs, but there has sill been no change. The link I posted which displayed a similar problem was solved with the user sending the cobra back to GHI. Anyone know of how to resolve this issue without sending it back? Thanks.

Hi Blue123, welcome to the forums - although I’m sad to hear you’re here because of your problem :frowning:

First step here is to tell us what devices are showing up in Device Manager in Windows, and whether it makes the USB device connection noise when you plug it in. We might ignore the white screen for the moment.

So open up device manager, look at the COM and LPT ports section if it’s there, check what is visible. Then, plug in your Fez and listen for the noise and look to see what device if any pops up in Device Manager.

Let us know what appears, if anything; that might help us with the next step.

Oh and as a cheap and easy change, can you also try with different USB cables? The mini USB cables have a very low rating for the number of insertions unfortunately, so might be worth grabbing another from the pile (I hope you have a pile of em :slight_smile: ) and try it out.

Hi, thanks for replying so quickly.
Trying different USB cables didnt work. However, when I plug the device in, device manager shows ‘GHI Boot Loader Interface (COM5)’ under ports (COM & LPT1). I forgot to mention, that I am running Windows XP on my system. Thanks.

@ blue123 - Well, it may simply be that there was a slight problem in connectivity that could have possibly corrupted the firmware during the write process. If you are seeing the device show up as the boot loader interface, then recovery should be a pretty smooth process. Please follow the directions listed here to manually update the firmware: GHI Electronics – Where Hardware Meets Software

Great news, as James says you should still be able to move forward manually; hope you get it sorted soon!

Hi, I’ve tried to manually update but this is also not working. When I press up, down and select and press the reset button, the device seems to just reset itself on device manager. I should also point out, that when the device is showing in device panel it has a yellow exclamation mark, which as far as I understand, indicates that there is some sort of hardware malfunction? Was wondering what I should try next. I have bought two of the best mini USB’s I can get my mitts on to try but to no avail. Thanks so much for your help!

Can you capture a screen image of the device that shows up in Device Manager? Post that up just to be sure.

Then once you’re in bootloader mode, you need to get the driver loaded properly. Open the device properties page, and try “update driver” and see what it does?

I have attached a picture of the Device Manager. I tried ‘Driver Update’, but the driver has already been updated. Thanks.

Slightly Bigger Screenshot of Device Manager.

There is no images


Your device is in boot loader mode. Direct it to the drivers in here C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_Bootloader_Interface

when drivers are loaded, you can continue with firmware update.

I click on the device and selected update driver. I then selected to ‘Install from a list or specific location’. I chose the file that you stated, but the message that the hardware update could ‘not find a better match for the hardware than the software that you currently have installed’ was displayed.

Oh yes, i see the driver is installed but it is complaining it is not functioning! Not sure why but please use a different USB port, do not use a hub or (best) use a powered hub.

Sorry, missed replying to you here. With the driver in this state, it would seem that you’re unlikely to get past this without removing the driver or finding what caused this (dodgy cable, low power etc). So the next thing I would suggest is to open the driver properties, and remove the driver, and make sure you remove the files. In device manager, open the device properties, then on the DRIVER tab, click Uninstall, then tick the “delete the driver software”. Click OK and stand back. Then unplug the device, cross your fingers, and plug it back in. When you need the driver, find it where Gus pointed it out earlier.