Main Site Documentation

Fez Cobra II Wifi Onboard (Error 12)


#1

Dear,

I have the following error on my wifimodule
at the instance of GHI.PREMIUM.NET.WiFiRS9110 --> IsLinkConnected i’ve got error 12 (see screenshot)

My wifi module boots but i can’t connect anymore to any network

I already tried to reïnstall the firmware but i receive time-outs

Yesterday it worked fine but today it worked anymore. And I always use an anti-static-carpet to lay my cobra on it.

Firmware is 4 .2.11.1
FEZ cobra II rev B
Onboard wifi RS9110-N-11-02

I realy hope this is solveble cause this is my exam in juin.


#2

Hi Alex,

I noticed your comment about reapply firmware failed - that’s something you really need to be able to do. Can you boot into bootloader mode and erase everything, or attach to the device in MFDeploy? If not, can you tell us what devices appear in Device Manager when you boot normally and into bootloader mode?

Did you have any thoughts about what, if anything, changed ?


#3

Hi Brett,

I already reflashed the firmware of my cobra several times but the problem still exists.

To answer your question about the bootloader, when I boot the cobra in bootloader mode I receive a extra com port (as it should) (see screenshot)

What I find rather strange is that the wifimodule itself can scan wifinetworks (see screenshots)

But not connect to them (2 days ago I could connect or ‘join’ them)

I did not change anything to my network neither to my code


#4

and I also flashed the cobra with an external powersupply


#5

I flashed the cobra for a third time with terraterm and now it works again !!

Thanks to Brett for your fast response.

The flash procedure can be found at
https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families#1834


#6

So I would be extremely surprised if this was actually your solution, but your statement implied you had some fundamental problem communicating from your PC to your Cobra2 (“I already tried to reïnstall the firmware but i receive time-outs” meant to me that you had timeouts doing the firmware update). Resolving that was necessary because it was pointless trying to troubleshoot any other issue when we didn’t know what was going on with your Cobra.

Personally, I would expect that you should have tried rebooting your wifi router as the first troubleshooting step. They are what I would see as the weakest link :slight_smile: