Main Site Documentation

FEZ Cobra II Wifi Module Died


#1

Hi All,

During one of my debugging sessions I have received exception that explains Firmware may be corrupted and needed to be updated.

I have used wifi.UpdateFirmware() method in my code to update it but another exception thrown 5 seconds later.

After I have tried my debugging the application cannot shown Firmware version in the console screen when enabled.

I have tried complete FEZ Firmware update but it did not help also.

How can I recover RS9110 module on my Dev board.

Thanks in advance.


#2

What exceptions are thrown? Can you show us a minimal example that reproduces the problem? Was your main code running fine and you randomly received that need to update message?


#3

Hi John,

When I tried to make firmware update I see the debug messages below and ends with a timeout exception

***** Debug Dump *****
Start Updating WiFi module firmware:
This might take up to 1 minute
0 Sec
1 Sec
2 Sec
3 Sec
4 Sec
5 Sec
6 Sec
7 Sec
8 Sec
9 Sec
10 Sec
11 Sec
12 Sec
13 Sec
14 Sec
15 Sec
16 Sec
17 Sec
18 Sec
19 Sec
20 Sec
21 Sec
22 Sec
23 Sec
24 Sec
25 Sec
26 Sec
27 Sec
28 Sec
29 Sec
30 Sec
31 Sec
32 Sec
33 Sec
34 Sec
35 Sec
36 Sec
37 Sec
38 Sec
39 Sec
40 Sec
41 Sec
42 Sec
43 Sec
44 Sec
45 Sec
46 Sec
47 Sec
48 Sec
49 Sec
50 Sec
51 Sec
52 Sec
53 Sec
54 Sec
55 Sec
56 Sec
57 Sec
58 Sec
59 Sec
60 Sec
61 Sec
62 Sec
63 Sec
64 Sec
65 Sec
66 Sec
67 Sec
68 Sec
69 Sec
70 Sec
71 Sec
72 Sec
73 Sec
74 Sec
75 Sec
76 Sec
77 Sec
78 Sec
79 Sec
80 Sec
81 Sec
82 Sec
83 Sec
84 Sec
85 Sec
86 Sec
87 Sec
88 Sec
89 Sec
90 Sec
91 Sec
92 Sec
93 Sec
94 Sec
95 Sec
96 Sec
97 Sec
98 Sec
99 Sec
RS9110 firmware update failed: Time out
#### Exception GHI.Premium.Net.NetworkInterfaceExtensionException - 0x00000000 (1) ####
#### Message:
#### GHI.Premium.Net.WiFiRS9110::UpdateFirmware [IP: 006a] ####
A first chance exception of type ‘GHI.Premium.Net.NetworkInterfaceExtensionException’ occurred in GHI.Premium.Net.dll
A first chance exception of type ‘GHI.Premium.Net.NetworkInterfaceExtensionException’ occurred in GHI.Premium.Net.dll
***** End of Debug Dump *****

After I receive this exception what ever I try I cannot connect to development board again until completely erasing und making tinybooter update by FEZConfig utility.

After FEZConfig operation I upload this siple program below

****** Post Update Application *****
public static void Main()
{
_wifi = new WiFiRS9110(SPI.SPI_module.SPI2, GHI.Hardware.G120.Pin.P1_10,
GHI.Hardware.G120.Pin.P2_11, GHI.Hardware.G120.Pin.P1_9);

        _wifi.Open();
        //_wifi.UpdateFirmware();
    }

******* End of Post Update Application ******

I see the messages below in the debug output

***** Debug Output ******
RS9110 firmware version Number is
RS9110 driver version Number is 4.4.5
****** End of Debug Output ******

I cannot see firmware version as itshould be.


#4

Did you try to call UpdateFirmware() after erasing and reflashing with FEZ Config?


#5

Hi John,

Yes I have tried it after applying TinyBooter update through FEZConfig Utility. But it did not recover also.

My main question is if there is any way to apply a firmware update through RS9110 module directly to recover the module.

I have made some research but it was limited and I could not find anything usable. I can make some wire connections and try somethings out of Cobra Board itself.

Thanks and Regards,


#6

@ AtillaBilgic -

If that comes from MFDeploy then it can be no problem, because sometime MFDeploy eats some your characters. :slight_smile:


#7

Hi Dat,

All the outputs are coming from Visual Studio Immediate Window. I have also another board and it is running as it should be.

Thanks and Regards,

Atilla