Main Site Documentation

Fez Cobra II not responding


#1

Hi,

I’ve been working on my Fez Cobra II tonight and suddenly the VS2012 debugger was failing to attach.

I then turned to Fez Config. The device shows up as being connected as in image. Then if I try and ping the device I get the next image.

I cannot seem to get the device to respond and it appears to me not to be a USB problem.

Can anyone think of anything I can try?


#2

I managed to get it working again by pressing combinations of the buttons and then updating the firmware using Fez Config.

I’m not sure exactly what I did though. I assume it was some kind of cold boot.


#3

Clear the loader flag next time


#4

@ JayJay, how do I clear the loader flag?


#5

I vote for the bold


#6

FezConfig has this in advance menu -> reboot CLR.
But in your case I don’t think it works, because to reboot CLR, at least PC can communicate with the device, here is you can’t.


#7

Hi I am having the exact same issue with my FEZ Hydra.

Can someone suggest things to try as my device does not seem to communicate with PC at all.

Attempting to deploy fails, pinging fails.

I have pressed the reset button and unplugged USB, restarted my machine, etc.

Nothing seems to work :frowning:

This is my first .net gadgeteer board and I was hoping to start this a hobby and I am failing at the first step :frowning:


#8

I can open a new topic, however because I am experiencing the exact same issue I assumed it would all be related regardless of the device…


#9

@ Squirrel_84 - There could be many causes. Can you start with this and let us know what you find please? https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#10

@ Gus Firstly thank you for a quick response.

I uninstalled everything GHI and NETMF related and I followed the instructions from the link.
I skipped step one as I am using VS2010 and selected NETMF SDK 4.2 (RTM QFE2). The 3rd step seems to be a repeat of Step 2 but I downloaded that anyway and installed and selected the repair option on running setup.
Once this had all completed I connected my device (FEZ Hydra) my PC then discovered the device and installed the software, recognising the device as a FEZ Hydra.
I then opened the FEZ Config application and selected “Ping” and had the same error appear :frowning:


#11

I realised that step 2 and 3 were not the same download my explorer (or me) got confused with what had been downloaded as, when I went to run “my first project” from VS2010 I had an error because NETMF had not been installed. So I had to again repeat Step 2 and 3.

However after running through setups for the 3rd time now, still get the same error :frowning:


#12

What same error? What do you see in device manager?

If you follow the troubleshooting guide I linked before, you will be able to fid the problem or at least tell us where you think you need help.

And I forget to say, welcome to the community :slight_smile: