Main Site Documentation

FEZ Cobra Board + WiFi module not able to access with 802.11


#1

Hey guys!

I found this WiFi class here:

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/html/7481f4d9-b4bc-f53d-e6bb-3a1ae861c9ef.htm

But both examples don’t work. When trying to excetue the first example the methode wifi.scan() throws an exception “not supported feature”. The second exmaple finds the network, but still doesen’t connect to it. What’s wrong with these examples, so that the FEZ Cobra Board with WiFi module can not connect?

I already tried to switching the encryption type and without encryption, but nothing works.

Thanks in advance.


#2

Which wifi module do you have?


#3

We found and solved the problem! =)
The adapter we are using has the type “ZeroG ZG100M_Compatible Wifi module”.
http://www.watterott.com/de/FEZ-WiFi-Erweiterung

It did not work because the example-code posted on ghielectronics.com is faulty.
http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/html/7481f4d9-b4bc-f53d-e6bb-3a1ae861c9ef.htm

The required network-settings are only being set, if the statement “if (WiFiSettings.Ssid != “AP-SSID”)” returns false. Which does not happen if the WiFi-Module finds the correct network from the beginning.
Also we activated the “use encryption” flag in the Method “Wireless80211.SaveConfiguration()”.

So we changed the code to this:

if (WiFiSettings.Ssid != “AP-SSID”)
{
WiFiSettings.Ssid = “AP-SSID”;
}

WiFiSettings.PassPhrase = “passphrase”;
WiFiSettings.Encryption = Wireless80211.EncryptionType.WPA;
Wireless80211.SaveConfiguration(new Wireless80211[] { WiFiSettings }, true); // “use-encryption”-flag change to TRUE.

Well, we hope this will help any other team who has the same WiFi-Module! :wink: