FEZ Cerbuino Net SD Issue

Hi, I’m trying to use the SD card on my FEZ Cerbuino, the first tyme has worked but then now I get the exception shown in the screenshot. How could I fix the problem?


Format your card on the PC and try again

Try to use a powered hub

Hi, I tried both but without success. The exception is thrown when I create the new SDCard(). The sd card works properly on pc. What could I try to do?


Have you tested other cards

make sure it is in FAT or FAT32 format.

Hi, I don’t know why now it’s working, but just the first time I call the function, the second time I get an exception on sd_card.mount. What could be the problem?


it’s long time since I used a Cerbuino the last time but if I remember right it can be that ‘sd_card.mount’ is already done in the constructor.
In an old project I found this snippet to initialize the SD-card.

if (!this.SD.Mounted)
            AutoResetEvent waitForSD = new AutoResetEvent(false);
            RemovableMedia.Insert += (a, b) =>
                var theA = a;
                var theB = b;
                this._fs_ready = true;
1 Like