Main Site Documentation

FEZ Cerbuino Bee Gettting started


#1

Just received this board and I’m looking for some getting started docs. i.e. What files to download and where to get them. I guess just some normal getting started information like I’ve received with other boards I’ve purchased. I must be overlooking something, doing some searches I find bits and pieces but nothing very comprehensive. I have a lot of experience with .net, c# and I’ve worked with .NETMF and I have 4.2 installed. I’ve also worked with Arduino boards, so I’m ok there. So, I’m looking for information on how it all relates to the Cerbuino board.

Thank you


#2

Welcome to the forum!

This will be a good place to start:

https://www.ghielectronics.com/support/netmf


#3

You can look at

https://www.ghielectronics.com/docs/45/fez-cerbuino-bee-developer

You must add the FEZCerbuino.Pin Class to work with the Digital and Analog Pins!
The best solution is to copy it from the website.

But you must add the GHI.Hardware.FEZCerb.dll to your References before.

After preperation you can work with the Cerb.


#4

This person is spamming us.


#5

You are right. I checked his previous 4 replies and he is pretending to answer :wall: His account is completely deleted now along with all related posts


#6

@ Gus - I’m sorry, who was spamming you?

Anyway, when I run the installer (setup), I’m getting an exception on “GHI .NET Gadgeteer SDK v4.2”. If I run it by itself, it just stops after running it. If I allow the bootstrapper (setup) to launch it, I get a .net unhandled exception

“Length cannot be less than zero. Parameter Name: Length”

I searched but couldn’t find any information this.

I’m running Windows 7


#7

@ ericO - It was somebody who posted here earlier (has been erased).


#8

@ Architect - Ahhh, ok. I never saw the post, didn’t know if you meant me :wink:


#9

@ ericO - Certainly not you! ;D


#10

No not you. Sorry about the confusion.


#11

@ Uuuups - I saw the link you posted, one thing I wasn’t clear on, do I need to load the firmware first? I assumed the board came preloaded.


#12

@ ericO - Checking/loading new firmware should be the first step. It is preloaded, but with the version that was available when board was made. Few new versions were released since then.


#13

@ Architect - sounds good. Any thoughts on the installer exception? Sounds like its missing an expected parameter. Is there a config file or can you pass the installer arguments?

thanks


#14

Are you properly extracting everything from the SDK zip file?
Do you have enough permissions?

This is a strange error. Check Windows events log, it might have more information about the problem.


#15

@ Architect - I extracted everything to a folder, seemed ok. I thought about permissions so I ran setup as admin. I did the same when I ran it by itself, I’ll check event viewer to see if anything is in there.


#16

Is this an English OS or a different language?


#17

@ Architect - English


#18

@ Architect - Checked Event Viewer but no errors. I see other messages that the installers created but no errors. I guess I can try to download the zip and try again, not sure what else to do.


#19

@ Architect - Good news! I downloaded the zip again, and re-ran the install and all went well. Corrupt package maybe, who knows. Anyway, thanks for the assistance with this.