FEZ Cerberus wont work

My Cerberus went back to GHI, but they tested it to be in order. The situation is as follows:
STDFU tester finds my Cerberus
MF Deploy finds it, and a ping returns TinyBooter (in Normal Mode) In boorloadee moder MF Deploy doesnt find it
PC sees it both in bootloader mode and normal mode. (MainLed and PowerLed are ON)
Erase with MF Deploy seems OK… No errors
Deploying the ER_Config and ER_Fash files give an ERROR in MF Deploy (files of date 24 May 2012)
Error: D:\FezDev\FEZ Cerberus\Firmware\tinyclr.hex\ER_FLASH.sig

When i run a small program in from the VS2010 C# or VB platform, the program starts to deploy
(only the LED7R connected to Socket 2, Power\usb client to Socket 8)+

namespace Cerberus
    public partial class Program
       void ProgramStarted()
            Debug.Print("Program Started");
            led7r.Animate(200, true, true, true);

after i hit RUN :
“Preparing to deploy assembies to the device” (this takes forever…) then sometimes an error of not finding a device is given…

Is there anything i can try ? I cant find any current firmware download links that work. the ones i Did find return a 404.

thanks for any ideas .


If you’ve been unsuccessful in flashing then you should not expect that you can deploy any programs. So, let’s focus on that. First, download a fresh copy of the GHI 4.2 SDK to be sure you don’t have any bad files. If that doesn’t fix it, try flashing again using

  1. a different USB cable
  2. a different USB port
  3. a powered USB HUB (a different one if you’re already using one).

Also, when deploying the flash files make sure you’re grabbing the files from
C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Cerberus\Firmware\tinyclr.hex

I think when I tried this the first time it was pointing to a 4.1 Hydra directory by default.

@ ianlee74 -
I tried your suggestions.
No Change…
The STDFU actions seem to work fine… i loaded the most recent DFU file with Success.

When i reconnect the Cerberus (without the boot jumper), it is recognised by MFDEPLOY, but what seems strange is that both the Red (power) and Green LED are on continiously. Only whil pressing reset, does the green led go off (untill i releas it again)
(in BootMode the green Led was NOT on…

any more ideas ? the same configuration works FINE for my CerduinoBee and Spider…

I sent the board back to GHI already, but they only tested it by doing a reflash (and thad DOES work)… cost me 2 x shipping already, Do i give it up for a bad luck or are there more things i can try

Are you compiling your own firmware? What is the version of the firmware? Use MFDeploy and select device capabilities from the target menu.

@ Aron -
I am following the instructions from the wiki item

I completed the first part, and when i come to the MFDEPLOY part i get stuck with errors.

I looked for a target menu in MFDEPLOY, but cant find it… are there more than one version of MF deploy ?

Yes there is. :slight_smile:
Under the help menu there is usually an about section that will give you the version of MFDeploy. However, the correct version of MFDeploy that should be used is located in this directory: [b]C:\Program Files (x86)\Microsoft .NET Micro Framework[/b] in either v4.1 or v4.2. In either of these directories is the directory Tools and you will find the file MFDeploy.exe. I cannot find the post but some other user had a similar issue and they were using something like 1.0 or 2.0.

@ Aron - I found a newer version of MFDEPLOY ( This one has Target Menu, but only these items:
Application Deployment - Create App Deployment and Sign Dep;oyment File
Manage Device Keys+
Configuration (Network and USB)

(this version also gives an error )


Bert, please go to this path: C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Tools and run the file MFDeploy.exe. The most recent version of MFDeploy is 4.2.

@ Aron -

AAAAHHHH… Thats the one i need…
OK Now i have the right MFDEPLOY…

and this time it went like a dream…

it works ( Tested the board with a quick program…)
youre the MAN !!!

now i hop i get my Cerbuino Bee up and running as well, as i must have ((&#@ # up something there in the proces…