Main Site Documentation

Fez Cerberus Unresponsive and most likely damaged


#1

Hi guys, I received my Fez Cerb yesterday and was eagerly attempting to transfer my code developed on my Fez Raptor board.
I went through the usual procedures of ensuring that the latest Firmware and Bootloader were on the board via Fez Config, I achieved the all-clear on this but when trying to run my code all would build ok, when I tried to run in a debug session this would never work, at this point I was thinking it must be my code which is causing the issue till I decided to remove all my code and just have a single line to illuminate the Mainboard Led. On the first attempt I successfully got this to deploy but without changing anything I would try to deploy again and it would fail with the message something like “There is an issue with you hardware”. I tried all the reset, clean, rebuild and deploy methods but sometimes it would work and other times it would not.

At this point I’m going through forums like this looking for answers till I finally did something stupid which was to connect my DP USB Module with 12V DC Power adapter connected to the DC socket and next all I get from my board is a Red Blinking Led which suggests to me that it is dead.

I have since ordered another 2 Cerberus boards, but I’m thinking I surely must be doing something wrong here, I mean I managed to get the Raptor board up and running, I guess I’m just another frustrated Software guy who just wants to write code instead of getting tangled up in all the electronics ends of things, below is the last error output that VS 2010 showed on a failed deploy attempt. If there’s any suggestions then that would be great, I don’t want to kill another 2 Cerberus Boards.

------ Deploy started: Project: DMQFusion, Configuration: Debug Any CPU ------
An error has occurred: please check your hardware.
Request failed
Source: Microsoft.SPOT.Debugger
Stack :
at Microsoft.SPOT.Debugger.Engine.Request.Wait() in c:\depot\current\CLIENT_V4_2\Framework\Debugger\Engine.cs:line 761
at Microsoft.SPOT.Debugger.Engine.SyncRequest(OutgoingMessage msg, Int32 retries, Int32 timeout) in c:\depot\current\CLIENT_V4_2\Framework\Debugger\Engine.cs:line 1963
at Microsoft.SPOT.Debugger.Engine.ResolveAllAssemblies() in c:\depot\current\CLIENT_V4_2\Framework\Debugger\Engine.cs:line 2941
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.Deploy() in c:\depot\current\CLIENT_V4_2\Framework\CorDebug\VsProjectFlavorCfg.cs:line 869
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.<Microsoft.VisualStudio.Shell.Interop.IVsDeployableProjectCfg.StartDeploy>b__0() in c:\depot\current\CLIENT_V4_2\Framework\CorDebug\VsProjectFlavorCfg.cs:line 634
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========


#2

I always go back to device manager to check what my PC is actually seeing. This is a good read as well https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#3

Thanks Gus, I will read over this prior to receiving my 2 Cerberus boards


#4

I wasn’t sure what you meant by this:

You said you deployed a LED blink app, isn’t that what a LED blinking app is meant to do ? :slight_smile:

Unless you mean the LED on the DP module, which means the protection on that module kicks in? It’s possible you fried something, yes, and Device Manager will go a long way to help understand what state it is in. I’d also recommend that you try loader mode to see if that changes what is connected.

Can you tell us what other stuff you hooked up to it ? I would struggle to see how this could have happened if you only had the DP module connected and only attached 12vdc to that module - that’s exactly what it’s meant to do.


#5

@ Brett - I’m pretty sure it’s dead in the water, the Red PWR LED on the Fez Cerberus blinks 2-3 times per second when connecting the USB SP power supply, also when I start up Fez Config, it always fails to ping


#6

This is what I see shortly after connecting the USB Cable to my computer for power.


#7

@ chillydk147 - Have you tried MFDeploy?


#8

@ Architect - No, I’ve been using Fez Config, initially I could ping the board and had the firmware/booter all up to date but since my little experiment with connecting a second power source to the USB DP, it has failed to ping since then.


#9

Please try. Does it appear in device manager after you connected it. What your last deployed code looks like?


#10

@ Architect - I tested it there now, no it does not, I don’t hear the little sound-clip that you normally hear when connecting a USB cable and device manager does not refresh, I also tested with connecting my Fez Raptor board and I do hear the sound-clip and device manager refreshes to show a new connection under the “USB Controllers” section


#11

DP module can handle 12V. It is within the input range. Try different USB port or even different PC if you can.


#12

@ Architect - I tried this with a different PC, same result


#13

OK. I would try to reload the firmware at this point.


#14

How do I do that if I can’t even connect via Fez Config??


#15

You can pres the loader button and power the device. It will boot in bootloader mode. There are instructions in the support section.


#16

It wont even do this, I tried this procedure before were you press the boot button prior to erasing via the STDFU Tester tool


#17

Out of ideas now. Does it blink the same when you connectbfrom USB or from wall plug?


#18

Yea does the same, it’s totally dead I’d say, I remember the other day that I had plugged and unplugged the USB SP socket from the board while the USB Cable was still connected to my PC, I’ve since read that doing this can damage the hardware.


#19

Does the board look OK? All parts in place, etc? Power socket not loose.


#20

Yes everything looks fine, I only received it this week