Main Site Documentation

FEZ Cerberus & STM32F4DISCOVERY - Please check your hardware


#1

Hi,
USBizi I am using all the projects. But now, due to lack of memory and a library. NET 4.2 and Cerberus FEZ (FEZ Cerberus & STM32F4DISCOVERY) I want to use. I have bought and set up.

Have created the first project, compiling and running.
But when making any additions (eg SD card) is compiled, but does not work!

VS2010 Pro on the computer right now, and July 23rd beta release, and processors installed (4.2.2.0) is available.


#2

Hi there,

Did you update firmware on Cerberus? When you do ping using MFDeploy what do you see?


#3

Yes, I installed the latest version(both pc and cerberus). Cerberus is the ping response.
Loading and running when I create a standard project.

But when I add any module fails.
Error message: Please check your hardware


#4

Start a new project from scratch… And add one module at the time…


#5

I believe that is how he got there.

[quote]Have created the first project, compiling and running.
But when making any additions (eg SD card) is compiled, but does not work!
[/quote]


#6

The attached screenshots.


#7

What modules are you trying to use? Are you deploying just the base program that is generated when you start a new project? If not, please post your code that you are using using the Code tags.

Also how are you updating the firmware? Are you making sure to erase the whole chip?


#8

@ Aron, the gadgeteer designer image in post 1 shows XBee, RS232, and SDCard.

@ ysoyipek you say that when you add ANY module, but your original image shows 3 added modules. Does adding any of these individually in the designer report the same error?


#9

TinyCLR TinyBooter and loaded. The attached screenshots.

It does not matter what I added to the module, because it does not work which one you add. Do not need the source code. The first project I created is an error.


#10

File \ New \ Project
Visual C# \ Gadgeteer \ .NET Gadgeteer Application (NETMF 4.2)
Add (Toolbox) GHI Electronics \ SDCard
Link SDCard board to F port

Start Debugging, Error!
Error 1 An error has occurred: please check your hardware.


#11

his profile shows he is in Turkey. as I remember there was a VS problem with netmf and the Turkish language.


#12

http://www.tinyclr.com/forum/topic?id=1562


#13

Now I’m trying

Thank you, started to work.


#14

Good catch guys


#15

I do have the same issue , im using Visual Studio 2010 with the German language is that the problem and when yes should I get an language pack or install it on english from scratch ?


#16

@ andre.m - ah thank you i’ll try it out .