Main Site Documentation

FEZ Cerberus help needed


#1

May be someone can have a new idea. I’m short of ideas now :open_mouth:

I’ve two Cerberus (hw v1.1) boards and I’ve updated both to 4.3.3 (both loader and fw). One board works like a charm the other has lot of problems, mostly not connecting to PC USB, not deploying from VS and I can’t ping TinyCLR from FezConfig and from MFDeploy. The board works fine in tinybooter.
It seems that 4.3.3 firmware is not ok on this board… Installing fw 4.3.2 (beta3) the board works fine…

No idea.

May it be an hardware issue ? I’ve used cables that work fine on the other board… I’ve erased all memory with DFU and flashed many times but I didn’t solved …


#2

Hmm, interesting, exactly like here. Two Cerberus boards, both working well on 4.2. Only one can upgrade…

I am not at home, but can you see if there is revision changes between the boards?

I will check when I am back.


#3

@ njbuch - uhhh interesting … I’ve checked and they are both “rev.1.1” and VS say 1.2 when deploying on the working board. The other no way to get connected. It seems some problem with USB. I will check components.
BUT it is still unbelievable that with 4.3beta3 it’s working fine…

EDIT: I’ve installed 4.2.6 last fw&loader, result: working fine. … mhhhhhh how can it be ?


#4

Are the boot loaders the same?


#5

@ Mr. John Smith - Yes they are the same and I checked and TinyBooter works fine on both boards.
Now I need to check HEX firmware files… you never know they got corrupted on all the 3 PC…
What I suspect is some configuration registers of USB port on the STM32F4 has changed to a critical value not valid for all Cerberus around …


#6

Just for an additional hint, the two boards seems different release. On the pcb they both report v1.1 but VS report 1.2 for working board and 1.1 for NOT working board.

I’m using in 4.2 SDK with no issue also with ENC28. :think:


#7

UPDATE: I dusted off my old win7-32bit laptop to try the update, ends with same result. The usb-driver does not seem to be the problem then…


#8

@ njbuch - Yes, It’s not a problem on the PC side.
I used Win8/Win8.1/Win7 with no result.

I suspect that something in the firmware is changed in last fw for USB Stm32F4 setup.
May be that v1.1 board has some errata on the chip ?

The tinybooter works fine. When flashing fw it goes messed up … Flashing fw with MFdeploy get same result.


#9

without real proof yet i have some sense that usb clock speed at the netmf board under 4.3 is less tolerant than previous firmware. One of my G400 boards won’t update if the gadgeteer cable between G400header and power module is > 10 centimeter or when the USB cable to PC is more than 1 meter.


#10

@ RobvanSchelven - Yes, this is what I’m supspecting. But changing cables, USB ports, HUB, USB3 USB2… no way.
The problem now is that there’s no more src code for GHI SDK and Firmware… :’(


#11

I also have two Cerberus boards that can’t be updated to 4.3. Any idea when these issues will be solved ?


#12

@ mrexwinkel - what is the issue. The update prices is not related to the netmf release, if we are using the st tools.


#13

@ mrexwinkel–
just download these file ,https://www.ghielectronics.com/support/netmf/sdk/21/netmf-and-gadgeteer-package-2014-r3

then install it
open GHI
first u have to ping it ,when see “Pinging… TinyCLR” its okay
goto frameware update, and next next ;).
if u had problem maby for ure power or " Pinging… TinyBooter" when u ping if its apeard u should go to advance menu and reboot clr . :wink: :wink:


#14

@ Gus: the two boards now have 4.2 installed. I successfully installed the new 4.3 TinyBooter. But after I installed the 4.3 framework using the GHIConfig tool, the boards are not recognized by the USB driver. Both boards have the same problem. I also have a FEZ Spider and I updated it with 4.3 without any problems.


#15

@ mrexwinkel - are you sure you have the very latest release? The one released this week?


#16

@ Gus: thanks, installed the last release and it works.