FEZ Cerb40 not response to ping via USB

I was bought Cerb40 soon. And got stuck: this one appears in device manager but not pinged by MFDeploy (No response from device).
This one powered from built-in miniUSB socket: I was solder LM-1117-3.3 on bottom side of board.
It goes with default MF 4.2, I wasn’t reflash device.

I was google it issue but insuccessful.

Hi Mike, welcome to the forum.

What does Device Manager show exactly? And please tell us what MFDeploy shows (take a screenshot).

Also make sure its MFDeploy 4.2 and not 4.1

No problem
Host system: Windows 7 Ultimate 64-bit (x86-64) (Samsung R60 plus laptop)
Visual Studio 2010 Express
.NET SDK 4.2 + .NET SDK 4.1

Justin, of course I use MFDeploy 4.2

What happens if you do device capabilities (I think that’s it as on phone) under plugin

Just nothing: “No response from devices”

Have you tried updating it with the latest firmware?

Thinking about it mine did the same after updating the firmware and before updating the tinyboot loader.

No, I tried as is. Because MF 4.2 inside I think that’s enough.

And how to fix?

Have a look here http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Cerberus

And http://www.tinyclr.com/forum/topic?id=7982

Hi Mike,

ok, you may assume there’s a current firmware onboard, but you should ALWAYS update the firmware on a new device to make sure it matches the SDL version you have on your PC. So definetely step through that process that Justin has kindly pointed out.

OK. Is shorting “LODR” pin with “3.3V” pin enough to place Cerb40 into tinyboot updating mode?

Yes then remove it to continue the process

Thanks, it works! Updating to firmware 7-23 beta resolved the problem.
And so, may be anybody has pin map of Cerb40 to MF Cpu.Pin enum?

Sure, here’s the developer page: http://wiki.tinyclr.com/index.php?title=FEZ_Cerb40_Developer
That has pretty much everything you will now want :slight_smile:

So, I probably wrote incorrect code previous time.
I trying enumerate pins and switch each to interrupt mode, and device hangs and stucks after pin at index 10 passed to interrupt mode.
Probably pin 11 (and 12?) are USB IO pins.
Now, I will reflash my Cerb40.