Main Site Documentation

Fex Spider not recognized


#1

I’ve just bought a Fex Spider. When I connect it to my computer, it does not be recognized. Also the attached display stays clear.
When I use the same USBmodule and display whith my Raptor all seems to work fine.
I’ve also tessted the spider on another computer but the result stays the same. The spider is not recognized and the screens stays clear.
Is there something else I can do?


#2

hi Tielemaj and welcome to the forum.

This is the troubleshooting guide I’d suggest first up https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting

There are two key things I always think about with an issue like this - first is that the Spider has DIP switches that control it’s boot behaviour, make sure you have them set appropriately, and second is make sure you can see what device, if any, appears in Device Manager and if the driver loads correctly, this will tell you where in the process the device is up to

We’ll be here to help, let us know what you find !


#3

Hello and welcome,

It can be helpful to know what OS you have and how spider is connected (usb hub, 2.0 or 3.0 , power by usb or separate …)


#4

I’ve used 2 pc with Windows 7 64bit. The usb-port is an onboard device.
There is no external power attached.
I’ve uninstalled the software an reinstalled it.
The first time, the device is recognized for about 10 seconds, then it reboots and the pc does not recognize it anymore.
I’ve tried all possible switch setting butt all with the same result.
In the device manager there only appiers an ‘unkown device’ in the usb-section.


#5

Just tried with an external psu. Same result. :’(
I wil try installing everything on a clean pc and connect it to that pc.


#6

Looks like reflash firmware is best way for this case!


#7

Just tried a clean pc, installed everyting, connect my spider but I have got the same result.


#8

Just tried to follow the procedure on https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families but I can not get the spider to be recognized in any way.


#9

Did you remove all connected modules except for USB Client DP module?
LCD also should be disconnected.

Also, are these switches #1,2,3 pushed to ON side?


#10

I did removed everything but the Usb client DP module and I put the switches to ON.


#11

please tell us what you see in Device Manager.


#12

See image. Its always ‘Uknow Device’ regardless of the jumpers.


#13

When you right click on it what is the hardware ids on détails tab ?


#14

See images. I don’t get a harware Id.


#15

Always after the installation. On the 3the pc was nothing installed but windows when I started. I have installed everything and connected the device. With the same result. Not recognized.


#16

@ Tielemaj -

Do you have USB Serial module or any device that allows PC communicate to your Spider via UART?

if you have, connect that to socket 11, pin 4,5 (TX and RX). push all switches 1,2,3,4 to on side.

Config baudrate to 115200. You can reflash Tinybooter / firmware by Serial, all next steps are same.
Do you know about teraTerm software?


#17

I do no not have the Usb-seriam module. ;-(