Main Site Documentation

Fails using battery power


#1

I apologize if this has been asked a hundred times, I searched but didn’t see anything specific to this problem.

I am running a Panda II, but I have seen the same issue with a Cobra connected to this same system. It is running a bunch of motors, servos, sensors etc. all running off an 18 volt lipo separate from the power to the Panda board.

With mini-USB powering the Panda II it runs fine, goes through 30 step sequence of operations, no problem. When I unplug the usb and plug 6volt DC into the 6-9v external connector, it runs for one step and then stops executing the program.

Any ideas?


#2

Does it reboot or just stop? I think 6V is the minimum for the Panda-II. Try a 9V source. You may be falling below 6V.


#3

It just stops.

Tried 9v but it fails the same way.

Also tested an AC power supply that produces 6v DC, and that works fine.

Problem seems to be with hooking up battery power to that connector.


#4

I am a bit confused in that a 6V battery will not work, but a 6V AC power supply will work.

The sounds like the batteries are having a problem sourcing the required current. If you have a voltmeter, measure the battery voltage when connected to the device.


#5

Yep, agree with Mike, your battery voltage is sagging as current demand increases. Better batteries are needed.

One other thing you don’t say but need to be clear on… ground connections from both power sources are connected, right? Sensors and such need to have a common gnd reference to the panda.


#6

had something comparable with the EMX dev board and a over loaded USB, when i plugged in the external power the board just rebooted, could be a drop when switching.


#7

Actually, not so sure your situation is like this one. Way I read the original post, it works on power alone but fails on batteries alone, no mention of dual power combo… but certainly another thing to be sure of!


#8

I have seen a similar problem. I was using CallPod Fuel Tank Duo and the system worked fine with an XBee and sensors, but after a few months it just decided to never fire the relay even if the battery pack was plugged in. Every test I could think of said it should work, the pack was able to supply steady 5v power and well over 500ma. Never did figure out why it stopped working on the duo. I am going to be coming back to battery powering as backup soon, so if you figure something out I’m all eyes. I’ve been hoping for the LiPo module, but nothing there yet.


#9

What about adding suitable capacitors to the 6V supply input or on the regulated output side?

These should be big enough to absorb the power supply fluctuations but not so big that they appear as a short circuit when power is switched on.

I had this very issue with a modem module where the supply was dipping below the 3.9V it required to work every time the modem transmitted data. I put in a couple of 150uF caps and now the modem works faultlessly.


#10

Thanks so much for everyone’s help!

I am using an Inex ZX-Servo 16 board (http://www.robotshop.com/content/PDF/manual-zxservo16u.pdf ) that is connected to the Panda II via a JST connector and the Domino extender shield (http://proto-pic.co.uk/3-pin-e-block-component-shield/ ), and it appears that it is the ZX-Servo 16 board that dies and that the Panda II is continuing to process instructions – contrary to what I said previously. I am trying some different batteries and regulators to see if I can figure it out. Will report back.


#11

As several of you suspected, the problem appears to be related to the power of the batteries - the system runs perfectly off of my ultrabook USB when it is plugged in, but it fails after 6 or 7 cycles if the laptop is unplugged (4 cell lithion ion); but then I tested it connected to the USB on my full-sized laptop with a 9 cell battery but unplugged, and that works fine.


#12

I don’t know if this will help anyone else, maybe its too obscure, but I wanted to post it just in case. I have 4 ESCs connected to the servo control board, and what I figured out finally, is that they each have their own BEC. So even though I thought the power supply to the control board was isolated from the other batteries, they were connected since these BECs were supplying power back to the board through the servo control connectors.

Once I turned off all the BECs on the ESCs, then finally the system would run reliably off of battery power.

I am not sure why when you plug in USB power to the Panda II from a plugged in computer that it works, and all other arrangements fail. Maybe someone on the forum can explain that.

So why does it fail with the BECs turned on? I read that if you want to run off the BEC then you should only ever have one BEC turned on. So if you are running multiple ESCs, you only have the BEC turned on on one of them, and OFF on all the others.

I haven’t tried that yet. I will try it since it would eliminate having the second battery, but it also could be that the other system is glitching the system when it is under load, and a separate battery is needed to keep the power to the Panda II clean.


#13

If this is a flying thing then it’s normally recommended to power the controller separately from the motors so you don’t get reboots in mid flight which could turn out very bad if it drops out of the sky unexpectedly.


#14

further to Ian’s comment, this is the first time you’ve elaborated on your setup. You would have got many more pointers earlier if you’d described the full setup at the start, as “motors” doesn’t imply ESCs.

The golden rule here is noise isolation, and if you need to (and I really mean no way to avoid it) share power sources with the micro and ESCs or motors in general, you’ll want to spend lots of time making sure you have no transients; which probably means you’re better off with separate power sources.

As for why it’s different/better with USB, once you get 5v from USB, the 5v VREG is no longer in play and no longer subject to the effects that the current draw from the motors has on battery voltage.

PS: BECs are notorious for being OK to run RC gear that assumes dirty power but struggling to produce clean power for anything else.