Main Site Documentation

Failed to update Fez Spider starter kit


#1

Hi all,

I failed to update my new Spider starter kit, please help review my update steps and advise what I did wrong

First of all, I’ve tried with FEZ_Config_v2.0.6:

_ I’ve connected the mainboard to USB client DP module and then connected to my laptop
_ In FEZ_Config, I clicked “Check device for update”, it returned below info:

Loader (TinyBooter) version information:
4.3.4.0 on this computer.
4.1.6.0 on this device.

The Loader (TinyBooter) not up to date. <<<

Firmware (TinyCLR) version information:
4.3.6.0 on this computer.
Firmware (TinyCLR) Version: Not present on the device.
The device is in Loader mode.
Click on ‘Reboot CLR’ under the Advanced menu to reboot the device.

_ Click on Firmware updater then clicked next , it found:

Config.hex
Firmware.hex
Firmware2.hex

_ Clicked on Next button again, it failed when checking Signature of " Firmware2.hex" with a pop-up dialog “Interrupt while deploying. Updating failed!”

Here is the output:

Device will be updated automatically! DO NOT disconnect or turn off the device!

Connecting to device…
EMX_Gadgeteer is connected
Please wait while rebooting in TinyBooter mode…
Found TinyBooter version: 4.1.6.0

Updating Firmware. Please wait…
Deploying C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\EMX\Config.hex
Deploying C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\EMX\Firmware.hex
Deploying C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\EMX\Firmware2.hex

thank you,
Nemo


#2

go to the advanced menu and update the tiny boot loader first. then update the firmware.

:whistle:

and welcome to the forum!


#3

Hi Mike,

Updating Tinybooter failed with below error

The loader cannot be updated if more than one device is connected. make sure that only one device is connected and that it is in bootloader mode.

please advise how to resolve above problem.

Regards,
Nemo


#4

@ nemolin - try rebooting your pic.


#5

Hi Mike,

I rebooted my PC and tried again but run into the same error :’(

thanks,
nemo


#6

Are you putting the DIP switches into ‘Loader’ mode?


#7

Hi Sprigo,

How to set the switch position to ‘loader’ mode? currently all switches (1 ~ 4) are in the same position (I guess all are ‘on’).

thank you,
nemo


#8

@ nemolin

Read this information:

https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families


#9

it works now.

thank you all for your help!

-nemo