Main Site Documentation

Executed in a Glide v 1.0.0 paradigm "Project with multiple Windows"


#1

Glide v 1.0.0, tested “Project with multiple Windows.” which would “Label” the conversion “TextBlock”. examples when executed, the error 1.button does not change the alpha. error 2. return “Window#3” twice, returning “Window#2”, did not return “Window#1”.


#2

It works fine for me on FEZ Cobra 4.3" 480x272 mode with EMX version is 4.1.6.0 on boot
I have a vague memory of issues when trying to use older version of EMX .NETMF


#3

However, the example of “Project with multiple Windows.” In the Glide 0.2.1, the work very well.


#4

This example has been updated.


#5

Hello,

I’m having trouble getting the glide example with multiple screens to work in a Gadgeteer application using Spider. I copied it into a ChipworkX application, modified the 3 screens by using my own xml, and it runs on my Spider set up just fine. All screens display and the “back” and “next” buttons work correctly. When I copy the project into a Gadgeteer application it throws erros regarding the Public Static Void Main(), saying there is more than one entry point defined. I understand the program generated cs already has a Main that cannot be changed.

I am a beginner so I have no idea what the Public Static Void Main() in the program.cs needs to be changed to in order for the program to work on my Spider set up.

Thanks


#6

Hello,

I tried successfully the example “Project with multiple windows” in the glide section. I had to compile glide but it worked on the first try !
Thanks for this nice example.

But now I tryed to add a simple button to it and the problem started :frowning:

I first used the glide designer to generate a new XML file including the new button.

As soon as i attach a new tap event handler to this button.
It immediatly raises an exception:
“An unhandled exception of type ‘System.NullReferenceException’ occurred”

I don’t understand as it is excacly the same process for the two other buttons on the window1…

can somebody please give me an advice how to fix this problem?
XML file is Ok and the debug shows me the GetChildByName is also OK.
I think the problem comes from the OnPress event.

Thank you beforehand.

code added:

Button L1Btn = (Button)window.GetChildByName("ButtL1");
L1Btn.PressEvent += new OnPress(L1Btn_PressEvent);


#7

If you single step the code past this line, you will likely find that L1Btn is NULL.


Button L1Btn = (Button)window.GetChildByName("ButtL1");

This happens when the name you use does not match what is in the XML file and the call to GetChildByName fails to find it. Check the name ButtL1 is the exact same as in the XML file. It is case sensitive.