Main Site Documentation

Ethernet module


#1

I hope I’m not being stupid, but anytime I plug in the ethernet module, the whole system dies, i.e. the power lights on the spider and the usbclient go out and the device is disconnected from windows. As soon as I unplug in the module, the system lights up and reboots.

I’ve tried, plugging the module both before and after the usb cable, and I’ve tried an external power source (I thought initially there was not enough power) and neither makes a difference. Even plugging the ethernet into the usbclient directly caused it to stop working.

Any ideas? Could it be a faulty module?


#2

Sounds like a bad module. Check the module for solder problems.

Can you check the resistance between the power and ground pins?


#3

To my untrained eye the soldering looks fine, but that doesn’t mean anything!

I’m new to hardware tinkering so I haven’t got the equipment to test the resistance unfortunately.

Thanks for the help, at least it’s a cheap module!

Has anyone used the Sytech Ethernet/microSD module? Coolcomponents in the UK don’t do the GHI ethernet module.


#4

Oh,is that what you are using? Sytech? If it is then check if they have a forum. I’ve seen Simon Taylor posted something on gadgeteer forum:

http://www.netmf.com/gadgeteer/forum/default.aspx?g=posts&t=2308

You might get his attention there.


#5

No, I’m using GHI, but I live in the UK and CoolComponents where I got the Spider kit don’t stock the ethernet module yet.

Also, I just read that the sytech module is only compatible with their Nano mainboard so that idea is out the window!


#6

Lets not forget that there was mention here previously that modules are not meant to be hot-plugged. The way you describe the problem seems like you’re hot-plugging? Can you try powering up with everything connected and see if that is any different?


#7

Good point! There is also schematics available for that module on the codeplex side. Might help when you check connections and any solder issues.


#8

Socket type of that sytech is Z not S. This is very sad and limits the use of their module. If they designed it properly with S type then this module could have been used on almost any gadgeteer mainboard.

Z = vendor specific.
S = SPI, which is what the ethernet EMC28J60 chip used on that module.

Now, even if a module is type Z, it MUST be safe to handle accidental use. Boards shouldn’t short!


#9

Thanks for everyone’s help. I’ve traced the problem to a dodgy cable - should have probably checked that before!