Error for connecting to webservice

Hi, I use a WCF REST Service Template 4.0 to establish a webservice,
Wen I run the service on ASP.NET Development Server(Localhost), it work.
I can visit the webservice in browser for example typing http://localhost:3910/Service1/
But when I test in Spider with wifi module, it is not work.
I test the method below,

WebClient.GetFromWeb("http://localhost:3910/Service1/").ResponseReceived += new HttpRequest.ResponseHandler(Program_ResponseReceived);

The error shows that I have wrong URL.
This method is working for calling other webservice, so I think the problem is my webservice.
Do I need set my webservice on IIS?

Other question is the Wifi Module,
Many times when I deploy the application, shows Error “Unable to communicate with device - USB:Gadgeteer”
Some times works and some times not works.
I need to unplug the Wifi, deploy a empty application(only Debug.Print(“Program Started”)) then re-plug the Wifi and deploy the Wifi application.
Its waste much time for me? what is the problem?


“localhost” only works when running on the same machine where the web service exists. It’s the same as calling To access from your Spider, you will need to specify the actual IP or DNS name of the computer where the web service exists.

Your deploy problem sounds like you have a tight loop somewhere. Try adding a small Thread.Sleep(20) in the middle of your loop if you indeed have one.

but when I change the http://localhost:3910/Service1/ to
The browser can’t visit it, the spider too.

That is probably then because it’s not hosted on a “real” IIS but just on the local Visual Studio enabled one… I haven’t done this in ages but I believe the local one only permits connections to/from localhost, there is no firewall rule enabling it. To properly develop this you will need to push the ASP.NET project to an IIS server.

Make sure you’ve disabled your Windows Firewall properly to allow external connections to your machine.

I do not use the Windows Firewall in my computer.
I have tried to push the ASP.NET project to an IIS server.
But the IIS make me craze, the IIS in my computer is IIS6.
To deploy the WCF REST Service Template 4.0 in IIS 6 is a terrible things.
I waste 2 days even can’t success run correctly on the IIS.
Michael Dodaro also give me some helps but not working yet.
Maybe finding other computer to install the IIs 7 then try again.
Very very frustrated .

Tzu Hsuan,

Try downloading IIS Express from Microsoft. I believe it has better support for REST type apps.