Main Site Documentation

Error: a3000000 on FEZ Cobra II


#1

Hi Guys,

I got FEZ Cobra II and decided to start programming it, but unfortunately I get
Error: a3000000 every time I want to deploy/debug under Visual Studio.

I got a powered USB hub (as suggested on on other threads) but still no success.

here is the output I get:

Found debugger!

Create TS.

Loading start at a0e00000, end a0e0fc38

Assembly: mscorlib (4.2.0.0) Assembly: Microsoft.SPOT.Native (4.2.0.0) Assembly: Microsoft.SPOT.Hardware (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.PWM (4.2.0.1) Loading Deployment Assemblies.

Attaching deployed file.

Assembly: Microsoft.SPOT.IO (4.2.0.0) Attaching deployed file.

Assembly: Microsoft.SPOT.Hardware.SerialPort (4.2.0.0) Attaching deployed file.

Assembly: Gadgeteer (2.42.0.0) Attaching deployed file.

Assembly: Microsoft.SPOT.Graphics (4.2.0.0) Attaching deployed file.

Assembly: Microsoft.SPOT.TinyCore (4.2.0.0) Attaching deployed file.

Assembly: Microsoft.SPOT.Net.Security (4.2.0.0) Attaching deployed file.

Assembly: Microsoft.SPOT.Touch (4.2.0.0) Attaching deployed file.

Assembly: System.Http (4.2.0.0) Attaching deployed file.

Assembly: System (4.2.0.0) Attaching deployed file.

Assembly: GadgeteerApp1 (1.0.0.0) Attaching deployed file.

Assembly: System.Net.Security (4.2.0.0) Attaching deployed file.

Assembly: GHI.Premium.Net (4.2.10.0) Attaching deployed file.

Assembly: System.IO (4.2.0.0) Attaching deployed file.

Assembly: GHI.Premium.System (4.2.10.0) ***********************************************************************

  • ERROR!!! Firmware version does not match managed code version!!! *

  • Invalid native checksum: GHI.Premium.System 0x8AF38F5C!=0x1D6C0EC2 *


Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: Gadgeteer (2.42.0.0) needs assembly ‘Microsoft.SPOT.Net’ (4.2.0.0)

Assembly: System.Http (4.2.0.0) needs assembly ‘System’ (4.2.0.0)

Assembly: System.Http (4.2.0.0) needs assembly ‘System.Net.Security’ (4.2.0.0)

Assembly: System (4.2.0.0) needs assembly ‘Microsoft.SPOT.Net’ (4.2.0.0)

Assembly: GadgeteerApp1 (1.0.0.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: GadgeteerApp1 (1.0.0.0) needs assembly ‘GTM.GHIElectronics.LED7C’ (1.0.2.0)

Assembly: GadgeteerApp1 (1.0.0.0) needs assembly ‘GHIElectronics.Gadgeteer.FEZCobra_II’ (1.1.4.0)

Assembly: System.Net.Security (4.2.0.0) needs assembly ‘System’ (4.2.0.0)

Assembly: GHI.Premium.Net (4.2.10.0) needs assembly ‘Microsoft.SPOT.Net’ (4.2.0.0)

Error: a3000000

Waiting for debug commands…

The program ‘[2] Micro Framework application: Managed’ has exited with code 0 (0x0).

The environment is : Visual Studio 2012 Professional Edition running on Windows 7 (64 bit)

Help would be greatly appreciated.

Regards

Fitim


Mike from GHI Electronics replied :

Most likely, the version of the firmware on the device does not match the installed GHI SDK.


#2

My next question is, where do I find the latest firmware for FEZ Cobra II?

Regards

Fitim


#3

[ol]Make sure you follow the steps listed on http://www.ghielectronics.com/support/.net-micro-framework
Also see: http://www.ghielectronics.com/docs/127/firmware-update[/ol]


#4

I have followed the steps as listed on http://www.ghielectronics.com/support/.net-micro-framework.

Tried to update the Firmware using FEZ Config, but in the middle of update, it failed (lost connection to the board) and then went to Start Over screen.

Now whenever I try to ping the device or get the version, the device gets disconnected.


#5

Unfortunately, your problems may relate to USB drivers and/or power. We recommend:

  1. if not doing so try a powered USB hub

  2. install the development tool chain on another computer and try it there (USB implementations vary widely across devices).

  3. You can also try the g120 legacy updater found here https://www.ghielectronics.com/downloads/firmware/GHI_NETMF_Firmware_Updaters_legacy.zip - follow the onscreen instructions. Note the Cobra II has buttons for LDR1 and LDR0


#6

You can always get a barrel power supply to plug in. I have a 2amp one from Maplins that does the trick when I have a CP7 screen plugged in. Its because USB only typically supplies 500ma max

Also try changing the USB port that your using. I had issues with USB3 ports on my new pc and had to swap around until I found one that worked. I think its because its now in a USB2 socket :wink:

I hope that’s helps :slight_smile:

Paul