Main Site Documentation

Error: 80131700 "the document cannot be opened" MMP. FEZSpider


#1

I’ve benn trying to set up my FEZSpider in MSVS10Professional, i have followed these steps so far:

1: http://www.ghielectronics.com/support/dotnet-micro-framework
installed the 2 files from this page.

2: updated firmware in FEZSpider.

when i load a new Project with my FEZSpider module i get the error shown in the screenshot.

Can anyone please help, i have tried troubleshooting this for several hours.

I am using Windows 8 on a MAcBookPro with Parallels Desktop(virtual machine)

Best Regards

Chris


#2

Thx…

I’ve made several windows form apps in win8 with VS2010, the mistake first came when i tried to program my FEZSpider

Nop i didnt knew that. Thx for a fast reply, i try run win 7 and hope that i wont get it again!


#3

However, there are many that use Visual C# Express 2010 without problems on Win8 (that doesn’t make it any more supported though).

There are known issues however with macs and virtualisation, although I can’t remember the details as to whether Parallels was explicitly called out as bad… from memory, bootcamp is the only way reliably to have that work; I’d suggest a quick search here on the forum for background. But the behaviour was about issues with USB and deploying, not directories - can you please tell us what you were attempting to do when you generated that error?


#4

I have no issues using Visual Studio 2010 on Windows 8. I don’t know what andre.m is talking about but it works great.


#5

Really?! I learn something new every day! :smiley:


#6

What that supposed to mean?


#7

Thats when i Rebuild the solution, and try to run it. With or without Debugging then it comes up!


#8

@ Brett: the things i do when i start it up:

  1. Clean solution
  2. Rebuild Solution
  3. run, have tried with and without debugging.

But i get the error no matter what!


#9

@ SpiderCred - This error usually means (well in my experience) that there is an intermediate file in build process that stuck and prevents the build process to finish.
Try closing the solution and delete bin and obj folders inside the project folder. Open the solution again and rebuild everything.


#10

The test I would always try is create a new project, drag a mainboard and a module to the designer, then deploy the code. If that works, there’s something wacky with the old project, so copy your code into the new project shell and see if that helps - if the fault comes back then it might have come with your code. Reduce what you bring over and keep trying to identify what.


#11

Ok, i just dragged in the motherboard in a new solution saved a new place (on the desktop) and pressed Build and there the Error came up again.

I tried to delete Bin and Obj, and then rebuild it. It came up with the same error.


#12

Ok. Do you have “Visual Studio Command Prompt (2010)” link/tile on your Start screen?


#13

Yep, its open now!


#14

Ok in that command prompt navigate to the folder where your solution is located. Once there run the following command: msbuild “your solution .sln file”


#15

ok just did. This happened, and the Windows features came up with the .NET Framework 3.5…


#16

Install that just in case.

In the command prompt window can you scroll all the way up and see if there is more info about the error?


#17

got this


#18

Hmm one thing I’ve noticed is that we have version mismatch. Here is mine:

[quote]C:>msbuild -version
Microsoft ® Build Engine version 4.0.30319.17929
[Microsoft .NET Framework, version 4.0.30319.18033]
Copyright © Microsoft Corporation. All rights reserved.

4.0.30319.17929[/quote]


#19

YES, the error is gone!

It was the .NET Framework 3.5 i needed to install.

i ran the msbuild in cmdprmt:
Still the same version though, but the build succeeded!

Thx for all the help, its been really appreciable. And nice to know that it works, so far, on Win8!

Regards a happy Newbie :wink:


#20

Great to hear! Running build from a command prompt shows more information. Some of it is suppressed by Visual Studio usually.