Main Site Documentation

EMX: PE-Files? Updating From VS2008 To VS2010


#1

Hi,

I just updated from VS2008 to VS2010 and to GHI NETMFv4.1 SDK. Now i have got the following compile errors:

Unable to copy file “C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\GHIElectronics.NETMF.Hardware.pe” to “bin\Debug\GHIElectronics.NETMF.Hardware.pe”. Could not find file ‘C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\GHIElectronics.NETMF.Hardware.pe

There are two folders “be” and “le” under Assemblies folder which both has these pe-files. Which one i choose?

Regards
jentze


#2

chose le.

I have seen it before where solution conversion didn’t work right. The easiest way, and best I say, is by making new project in VS2010 then move your files over manually
…you do not want to end up with some strange problem than no one can explain :slight_smile:


#3

Hi;

Thank You very much. It helped.

regards
jentze


#4

Hi,

Now i have updated from VS 2008 and NETMF V.4.0 to VS2010 and NETMF V.4.1. and TinyBooter also. Everything is fine, BUT PPP.Connect hangs and does not make connect. I have DHCP enabled with MFDeploy. Exactly Same project runs on VS2008 and NETMF V.4.0 where PPP.Connect works well.

Have you changed a lot PPP class?
Maby NetworkAvailabilityChangedEventHandler does not work?

Regards
jentze


#5

I suggest you start new topic now with this issues and please provide more details, like where is the modem connected and what is the modem brand, some code snippets… anything that you see helps.

The right engineers at GHI will help you out.