Main Site Documentation

EMX Module not responding... possibly codeless


#1

Using the EMX module on a custom baseboard I do not get the USB driver to ‘detect’ the EMX.
Using the Development System the EMX is detected and MFDeploy is communicating OK.
The LMode Pin is strapped low for USB Interface selection.
I’ve tried a second EMX module with only the Supply’s and Host USB connections and LMode connected with the same result… No USB connectivity :(.

Is it possible that the EMX modules received is without the bootloaders or drivers??

I did not make provision for the serial (Com1) interface on my base board for emergency access.

What is my options and how can I verify an operational EMX module?


#2

You mean USB client? Are you sure you have the correct USB pins connected and they are not swapped?


#3

Did you do more than one custom boards and one of them is not working?


#4

Problem solved… I was trying to connect on the Host Port and not the device Port :-[

Thanks Gus for the prompt response.