EMX : Legacy USB driver not working at October 24th package (with solution !)

After updating my EMX-module to October 24th package, it was not possible to connect via USB to my XP computer.
Trying to install the legacy driver (yes - with manual pointing to the driver-files !) failed.

After investigating some time, I’ve found the solution:
My PC is recognizing EMX with a “VID_1B9F&PID_0106” at USB connection.

But the actual driverfile “GHI_NETMF_Interface.inf” contains informations for PID_0102.

After doing a simple search and replace PID_0102 to PID_0106 with a text editor,
my system connected to EMX without problems.

One additional info:
I am running XP (SP3) as a virtual machine using VM Ware 8.0


Thank you - you are my hero!

That is because we now use WinUSB driver. You can do what you did to force the legacy drivers but that is a bad idea as you should be using WinUSB drivers…unless the reason is that WinUSB doesn’t work with VM?

WinUsb didn’t work onto my machine. Already have done all XP - Updates (SP3) but driver installation always failed.
I’ve already told you in another thread.

This is why I am forced to use the legacy’s…


I ran into the same problem on a XP SP3 system (real hardware, no VM)
The new WinUSB driver failed to install every time so I needed to use the legacy driver.
But for EMX it is not accepted because the .inf file is wrong PID_0102 instead of PID_0106.
After ‘manipulating’ the .inf file it worked.

Correct, WinUSB seem to work fine on vista, win7 and win8. The next SDK coming this week will make this simpler fro everyone.