Main Site Documentation

EMX GUI support reference example


#1

I am working with EMX tool of GHI. For GUI i am expecting libraries or code reference of Buttons,toggle buttons, lables, textbox, keyboard, spinners, tab, scrollbar, listbox and gridbox and graph controls fro my project GUI design.

Can any one suggest the reference library or refence codes for the same.


#2

http://msdn.microsoft.com/en-us/library/ee435580.aspx

See Microsoft.SPOT.Presentation and See Microsoft.SPOT.Presentation.Controls


#3

Thanks for the reply and the link. Can you please suggest the example reference with using this libraries?


#4

Try this:

I haven’t looked at it personally, so I don’t know how good the code is, however it is GHI’s official demo so I can only assume it follows best practices.


#5

http://www.innobedded.com/

Make a nice WPF library but they do charge for it.

Dale


#6

Niraj,

Pyxis2 has nice set of custom controls:


#7

Hi Architect,

Thanx, for sending a link for Pyxis2. I have downloaded Pyxis2_Beta 2.2, It seems helpful for presentation. For testing in have tried to dump it on Microsoft Emulator and EMX device, but it is giving error “Device not found or cannot be opened - USB:ChipworkX”. From the doucment i found that “This release is geared specifically towards the FEZ Cobra (though ChipworkX support is planned) with an attached LCD.”

My query is can Pyxis2 works with EMX of GHI? If yes then what should i do to smooth dump on EMX for testing?


#8

Niraj,

The error you’re getting is because the solution was last saved attaching to a ChipworkX device. Go into the project properties -> Deployment and select either Emulator or USB -> Your Device.

I have not tested Pyxis on the EMX but it should work well. There will probably be an instance or two that you’ll need to modify Pyxis as it changes its behavior based on the active device.

Feel free to put any bugs on the Pyxis CodePlex page, email me directly, or keep posting here for support :wink:


#9

Niraj…that happens other people’s projects sometimes…just go to the project proerties, RESELECT USB and EMX (even if they look selected now), then try to deploy again, you should be able to this time.


#10

I have tried with settings through project properties -> Deployment and select either Emulator or USB -> Device. and even by reselecting USB and EMX but still it is showin same error message as “Device not found or cannot be opened - USB:ChipworkX”.

Kindly suggest next action for smooth dumping.


#11

You could check for a reference to the ChipworkX device. There shouldn’t be one, but who knows. I’d check myself but CodePlex is currently erroring out on download and my local copy is much newer.


#12

I have make a new solution and add all files in the new solution but while building its giving error “CLR_E_OUT_OF_RANGE”. I am not getting how to execute the code either in emulator or EMX. Can some one help to find the solution.