Main Site Documentation

EMX: EMX Updater fails


#1

I have used new EMX boards on two PCBs.

First they started up fine with the Debugger Interface.

Then I had to down-date them for a 4.1 applicarion.

Then I split the the memory in two for the 4.1 application updates from SD Card.

Then the Debuger Interface statted to be unstable and I got resets.

Then I tried EMX Updater again to clear them…

Now they fail in the EMX Updater @ 1/2 way througn CLR.HEX
And in the EMX Firmware Updater (4.2) @ 1/5 og the way througn Firmware.hex

It is exactly the same on both EMX boards… no way back, it seems.

The Debugger Interface does not show up - but the tinybooter is OK.

What to do?


#2

@ nsb - If I have any issues, I always go back to the old way of updating my EMX’s. Check this page out, http://wiki.tinyclr.com/index.php?title=Firmware_Update_EMX


#3

I have now tried this, too.

TeraTera goes OK… with the TinyBooter

MSDeploy fails exactly in the same position in the CLR.HEX file.

This goes for both EMX modules.


#4

ok, can you do another test? If you have another PC, can you install the SDK again there and see if you can do the full install from there? I had an issue I never tracked down exactly what happened, but refreshing the SDK seemed to make a difference to the installation of the firmware update (I even compared the actual firmware files and they appeared to be consistent, but one would apply one wouldn’t)


#5

I have tried anoter PC with a other download - the same result!

BUT, in a desperate try I did:

  1. Installed TinyBooter with TeraTerm

  2. Startet MSDeploy and installed CLR2.HEX and Config.HEX, only.

  3. Closed MSDelpoy

  4. Started MSDeploy and installed CLR.HEX, only.

Now, came over the crash point in the CLR.HEX :slight_smile:

And the EMX did a reboot and it is up running :slight_smile: :slight_smile: :slight_smile:

IT’s ALIVE…

So, the question:

Why did it crash in the first place, on the memory split for doing application updates from sd cards?
I have used this for along time with out any problems… is it a bug in the latest GHI firmware?

I will try all over again… and see if the problem repeats.