Main Site Documentation

Email Preferences


#1

We’ve added email preferences to all accounts. You must now opt in to receive email notifications.
https://www.ghielectronics.com/account/settings


#2

I just updated my preferences, including the newsletter. Clicked Save, all worked correctly, but ended up on a page that had a button to subscribe to the newsletter. Me being me I clicked it - got to a different page that had my email address, submitted it, and it gave an error. Perhaps this second subscription process is now redundant and should be removed or the setting shouldn’t be shown if I’m already subscribed ?


#3

Weird… I didn’t get what Brett saw. Mine just saved as expected.


#4

I can confirm the same behavior as Brett is describing. Maybe the text should be changed in, once detected that your account has already a newsletter subscription into [em]Unsubscribe Newsletter[/em]


#5

maybe I’m special - or maybe not. I can still repro it. https://www.ghielectronics.com/newsletter is the page I ended up on.

Edit: really, that page seems redundant, since I have to opt in to the entire email thing, having a separate newsletter subscription page doesn’t make a lot of sense.


#6

Odd. I got the same behavior that Ian did.

I’m on Win8.1, IE 11, FWIW.


#7

I am too, so that’s not it. Were you already subscribed to the newsletter service before today ? I was…


#8

I was.


#9

that theory is busted too then. @ Josh to the rescue… :wink:


#10

Of course, it doesn’t really matter now but I would have defaulted all the settings to “on” and let people opt-out so as not to interrupt the existing behavior. Lots of people won’t read this thread and will just stop getting emails.


#11

Can’t say I disagree, but I wonder if the reason behind this is legislative - in AU we had a change come in many years ago now where you had to explicitly opt in to continue receiving email from commercial entities, so the approach most used then was to send a last email along the lines of “dear reader, if you do nothing you will no longer get our newsletters; go here to update your email preferences including opting in to future postings from us”


#12

That would be fine too. So far, though, I haven’t received any such email.


#13

Maybe it has something to do with US residents and Non-US residents ?

That with the newsletter thingy.


#14

@ andre.m - :wall:


#15

Or me :open_mouth:


#16

go on, click it… :wink:


#17

I’m the opposite, obviously… that was why my original post said “me being me”, I clicked it :slight_smile: Call it “lowest common denominator testing” ;D


#18

@ Brett - So you got this nice confirmation email too ?


#19

The “Subscribe to Newsletter” button on the account landing page has been removed to clear things up.


#20

no, no email for me…