Main Site Documentation

Driver Issues


#1

Guys,

I’m coming back to my device after some time away on a clean computer. My Domino is set up to debug through COM via an FTDI breakout so I can use the onboard USB.

Now I’m having issues with the drivers. The FTDI drivers installed fine and I can ping/deploy via that over COM3, however the onboard USB drivers come up as CDC VCOM in Device Manager and my Windows 7 refuses to install the drivers for it, despite pointing it at C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_NETMF_Interface etc.

What’s going on, am I missing something?


#2

Never mind, seems loading in bootloader mode seems to have spanked it into doing something. Works now :slight_smile:


#3

Actually no, that hasn’t fixed it :frowning:

Using the bootloader mode it will load as COM4, but a normal reset will just bring it up as CDC VCOM and Device Manager wails.


#4

Maybe some old project is left on the board? It is a good idea to enter GHI loader, then erase all using E then reload firmware.


#5

Nope wiping the program and the firmware didn’t do anything for it :frowning:


#6

FEZ in loader -> you get a virtual port
load the firmware -> you get a NETMF interface device

…if you see anything else then windows is somehow loading the wrong drive?!


#7

Yeh might uninstall everyone and reinstall and see what happens.


#8

Sigh still won’t have it!!!


#9

I am not sure. Are you debugging over serial (FTDI)?
Then you used our USB client feature to make a CDC? The drivers for CDC have a link under CDC documentation in our library.


#10

Aha, seems I needed the .inf from the manual! Installed now thankfully.


#11

Yeh that was it Mike, I was missing that bit of information from last time :slight_smile: