Main Site Documentation

Domino with rs2323 shiled from CuteDigi


#1

Hello,
I have a Fez Domino with a rs232 shield.
when I run the program in debug mode everything runs ok, but if I run it without the debug, all msgs from the GC go to Com1.
If I disable the GC messages (Debug.EnableGCMessages(false)), I´m not able to send msgs to Com1.

Anybody knows this problem ?


#2

When you say “debug mode” - do you mean that you are running the application without being attached to Visual Studio ?

What is your debug interface ? USB or COM ?

Do you have a jumper on the mode pin ?

Do you call Configuration.DebugInterface.Set ?


#3

Hello,

When you say “debug mode” I mean I have the VS running.
The debug interface is USB.
No I do not have a jumper in the mode pin; by the way what is reason for that pin.
No I do not call Configuration.DebugInterface.Set. How can I do it and what’s for ?

Thanks for the help


#4

By default the debug interface on the Domino is USB. However you can change that to Serial (COM1) using the MODE jumper.

Doing this will allow debug over serial using a RS232 sheild (like the Digi one), a FTD232 board etc.

Since you are seeing the GC messages appear over COM1, I was wondering.

I may be missing something and let some one else pitch in.


#5

Messages only go to com1 if you set mode pin to select serial debug interface.


#6

Hi

I´m using the usb cable connect to my PC and I can degug with no problems.
With VS running I see all the ‘Debug.GC(true)’ comming to my screen and the application runs ok; if I disconnect the usb cable and power on the domino (there are no pins in the mode pads) all the msgs comming out from the 'Debug.GC(true) action appears in the rx pin and then are sent to my external devices (I do not want of course).

Strange and I can not find the cause.
Thanks


#7

right now I’d be looking for solder bridges or other unusual things around the MODE pin


#8

Gus,

I tried with several Domino and I noticed the problem only appens if I do a reset; in the case of a power off /on the program runs well.
I also have a Fez connect shield attached.


#9

Please provide setup and details for us to repro.


#10

Hardware: Fez Domino + Fez connect + RS232 Shield from CuteGigi.(Com1; 38400)
I´m using VS 2010 Pro edition.
GHI SDK is the last vesion
The following DLLs are used:

‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\mscorlib.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\Microsoft.SPOT.Native.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\Microsoft.SPOT.Hardware.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\Microsoft.SPOT.IO.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\FEZDomino_GHIElectronics.NETMF.FEZ.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.W5100.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.W5100.Dhcp.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\System.Xml.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.W5100.Http.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.System.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.IO.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\Microsoft.SPOT.Net.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\Microsoft.SPOT.Hardware.SerialPort.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\Microsoft .NET Micro Framework\v4.1\Assemblies\le\System.IO.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.Hardware.dll’
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded ‘D:\ISEP\Mestrado\Programas\FezDomino\FIAS\SimplyFias V1.0.1.0\SimplyFias\bin\Debug\le\FEZ Domino Application.exe’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.dll’ (Managed): Loaded 'C:\Programas\GHI Electronics\GHI NETMF v4.1 SDK\Assemblies\le\GHIElectronics.NETMF.Net.dll’
The thread ‘’ (0x2) has exited with code 0 (0x0).
The thread ‘’ (0x1) has exited with code 0 (0x0).

One question : even with Debug.EnableGCMessages(false) theGC runs when I do Debug.GC(true) in the application ?
Asking because the application crash even in debug when I disable the msgs …
Thanks


#11

We always running test on a very small test program. You have too loaded to locate any errors


#12

I spent some time to look through this. I did my tests on a Panda and am sure that debug messages will appear only if the MODE pin is set.

My test code (from the wiki):


            SerialPort UART = new SerialPort("COM1", 115200);
            int counter = 0;
            UART.Open();
            while (true)
            {
                // create a string
                string counter_string = "Count: " + counter.ToString() +
                                        "\r\n";
                // convert the string to bytes
                byte[] buffer = Encoding.UTF8.GetBytes(counter_string);
                // send the bytes on the serial port
                UART.Write(buffer, 0, buffer.Length);
                // increment the counter;
                counter++;
                //wait...
                Thread.Sleep(100);
            }

If I have my interface set to Serial (COM1) I can see debug messages on reset.

@ General - are these the messages that you are seeing ?


#13

Hi,
Yes some kind of …
All the GC msgs generated by the Debug.Gc(true), goes to the Com1 (Rx pin). It happens only if I have the isb cable disconnected; if it is connected I received them in the screen; I´m debuging useing usb port.

Anyway I found other strange begavior on my Domino I´m investigating; I do not know yet if it is a problem with my code (too big) … Thanks