Main Site Documentation

Doa panda 2?


#1

Hi,
after almost 2 weeks waiting, today my FEZ Ultimate Kit arrived with the Panda 2 included.

I had VS2010 ultimate already installed so I decided to reinstall the NETMF 4.1 (was already installed because I own a netduino), installed the GHI SDK (x64), installed the USB drivers. Installed Tera Term Pro (followed the link on the GHI page).

After the installations I connected the PANDA 2. Unfortunately didn’t recognize the device, (no windows sound to tell you a new device was found). On the PANDA 2 the led was blinking but that was it.
The device manager didn’t show anything new as well.

After reading the forum, I swapped out the USB cables (2 cables delivered by the package, 1 self owned), tried different USB ports, even tried another machine. all the same result => windows wasn’t recognizing the PANDA 2.

Based on the chat (Thanks Mike for helping me out for more than a hour). I tried the TeraTerm, but when holding the loder button on power up no COM-port showed up in the TeraTerm app, nothing was shown either in the device manager.

I have the feeling this panda somehow died while arriving…

As an atachment it is the devicemanager while having the panda 2 attached

the following link is showing the TeraTerm app:http://www.micheltol.nl/teraterm.png

I’m clueless, already uninstalled all the drivers, reinstalled everything.

already uninstalled everything netduino related… but still no success!

If anybody has any idea … plz let me know!


#2

Sorry to hear about your troubles. All boards are tested more than once to assure quality so I am surprises to hear about this! The easy way to handle this is by shipping panda back and we will test it for you. Contact GHI to get an RMA. You may want to only return panda instead of the whole kit to save on shipping. We will get you a replacement the same day we receive yours.


#3

I went over all the steps that Michel performed and he seems to have done everything correctly. The 64 Bit drivers etc. I am stumped!


#4

Tried a final test now testing it on a win xp 32 bit but still the same issue… completely not recognized by windows…

@ Gus I’ll do.


#5

Jeff suggested that you might want to check the solder joints on the min-usb connector. Might be a cold solder joint.


#6

Speaking of that, is the led lit on your board?


#7

He said the power led was lit and the other led was blinking.


#8

Very strange! LEDs are active but USB us dead.


#9

Yes strange…


#10

Gus,

maybe a stupid question, but are you talking about multiple leds? I don’t have my panda near me but I could remember that there is only one led (near the USB connector next t the R22) burning. This led was blinking when the USB was connected.


#11

Yes that. this means it is working!!


#12

The blinking LED is due to a test program that was loaded on the Panda. The blinking LED indicates that the processor is running and that the USB port is supplying power. It still sounds to me like the D+/- lines on the USB connector have a cold solder joint.

A few months ago I accidental pulled the USB connector off a Domino (my fault). Luckily it did not pull the pads up for the USB connections. I was able to superglue the connector in place and then soldered the pins back to the pads. I had quite the time trying to figure out how to reach the pins with the soldering iron and had a similar problem where the board had power but would not show up as a USB device (or would show up as an unknown device.) With some more flux and patience I was able to re-solder the USB connector and it has run fine since.


#13

Hi Just wanted to let you know, today I received my new PANDA II.

It is working like a charm! Thanks everybody for your support via this forum & the chat!