DisplayTE35 Touch Not Working


I have a Fez Raptor which I got over the Thanksgiving Day Feztivities which I am very happy with… I purchased a DisplayTE35 module a couple weeks ago to bring some visualization to a program I am in the middle of writing. However the touch capability does not seems to work. I have tried several cables and several variation applications that uses the touch. Has anyone encountered this and what was you resolution to it?

I am on Windows 8.1, VS 2013 Community Edition, SDK R5.

using System;
using System.Collections;
using System.Threading;
using Microsoft.SPOT;
using Microsoft.SPOT.Presentation;
using Microsoft.SPOT.Presentation.Controls;
using Microsoft.SPOT.Presentation.Media;
using Microsoft.SPOT.Presentation.Shapes;
using Microsoft.SPOT.Touch;

using Gadgeteer.Networking;
using GT = Gadgeteer;
using GTM = Gadgeteer.Modules;
using Gadgeteer.Modules.GHIElectronics;
using GHI.Glide;

namespace Raptilean
    public partial class Program

        // This method is run when the mainboard is powered up or reset.   
        void ProgramStarted()
            var cal = new GHI.Glide.Display.CalibrationWindow(false, false);
            cal.CloseEvent += cal_CloseEvent;
            Glide.MainWindow = cal;

        void cal_CloseEvent(object sender)
            //Do something here


@ kirklynk - Does touch not work at all or do you get incorrect values?

I am getting nothing from the touch. The calibration window still displays touch the screen to start. I have touched all over the screen and nothing :’(

@ kirklynk - Have you tried using shorter cables for touch? Does https://www.ghielectronics.com/docs/162/touch#1591 work?

Thanks for your responses

Yes. I have tried both examples and the cables I have are all 10cm in length. Last I flash the bootloader and firmware on the Raptor to see if this will solve the issues but no look.

Kind a disappointed that this is not working correctly because it is putting a damper on my festivities. Next week I will purchase the T43 to see if that is a better display, why purchase a new unit when this not working? Simple answer, go big or go home.

@ kirklynk - Stop by the office on Tuesday with your display and we will see what we can do.

Thanks Gary. However after purchasing the bigger display which work perfectly I opt to try the DisplayT35 again. What I found was that the display ribbon cable was slightly detached from its circuit board. Once I reseated it, the touch works perfectly on the DisplayT35

@ kirklynk - great news, I am glad you figured it out.