Main Site Documentation

DIfficulty Upgrading TinyBooter on G400


#1

I have one G400 Beta Test Kits and I am having difficulty running the TinyBooter Update Procedure. I connect the board directly to my Windows XP computer USB port and I see
"Debuggable .Net Micro Framework Device -> GHT .NET Micro Framework USB Debugging Interface show up in Device Manager.

If I ground PA11 when I power-up board ( only holding ground for ~1.5 seconds) I do not see any change in that I still see the GHI .NET Micro Framework USB Debuuging Interface show up and nothing else new in Device Manager.

If I run FEZ Config v1.3 G400_G400 shows up. I then connect to it okay.
I can see device capabilities under Advanced . Most items shows as Version : 4.2.0.0

If I push the Device Version button it takes about 30 seconds and reports the following:

Loader (TinyBooter) Version:
Firmware (TinyCLR) Version: 4.2.0.0

and then pops up a window reporting " No response from device" with an OK button.

Any ideas what I am doing wrong or things I should try?

Thanks


#2

@ trapperbob -

Not sure if it will help but I recall (I think) that I had trouble at first.

I remember it was a bit awkward but I had to disconnect the USB cable from my PC which REMOVED POWER from the device. I then held the wire to PA11 and with my other hand, reconnected the USB cable. Held the wire jumper for about two seconds and then removed it… and then it worked…

Good luck!


#3

@ willgeorge-

Thanks for the input. That is exactly what I did to no avail. Still trying!

Thanks


#4

@ trapperbob -

No insult intended!
Are you sure you have the correct pin jumpered?

I have no idea but maybe you have to hold the jumper a ‘bit’ longer… I know, I was a bit worried about holding it too long…


#5

@ willgeorge-

I believe I am. I am jumpering the 15th JP2 outside position to the the 29th outside position on the mainboards of the Beta test setup. If I turn the board over the silkscreen labels show PA11 on the outside row paired with PC18 on the inside row. The last pair are both labeled GND.

Thanks


#6

Typically what you’re seeing is when you don’t hold the connection long enough for the bootloader to start, figure out it has the jumper set, and that it needs to then stay in BL mode. Try it for a much longer time, say 10 secs. Have Device Manager open while you do it and see if it shows a COM port at all.


#7

@ Brett-

I tried leaving it jumped longer but do not see a COM port at all.

Thanks


#8

@ Brett -

Try it for a much longer time, say 10 secs

I believe there is a warning not to hold it longer than 3 seconds or damage will result?

Just a comment…


#9

I tried doing the same procedure on another Windows XP computer and still have no success. All this has been with the same brand new beta kit from GHI. What can be wrong?


#10

@ trapperbob -

Wild guess on my part…

Have you installed SAM-BA

From G400 Beta Firmware Update

The following steps should only need to be completed once:

Go to this link: http://www.ghielectronics.com/downloads/beta/G400/ to download the G400 Beta Programmer and Atmel’s SAM-BA In-system Programmer. It may be necessary to deactivate the Active Scanning feature on your PC’s Anti-virus program because your system may freeze. You may also go directly to Atmel to download the SAM-BA In-system Programmer here: http://www.atmel.com/tools/ATMELSAM-BAIN-SYSTEMPROGRAMMER.aspx
Before you can update, the Atmel SAM-BA In-system Programmer must be installed for the G400 Beta Programmer to function.
Once the G400 Beta Programmer is downloaded, you will only need to unzip the file and follow the steps for updating the G400.


#11

@ willgeorge-

I have installed SAM-BA v2.12 as specified in the instructions.

Thanks


#12

@ All-

I have at least got past the initial recognition stage. After seeing the discussion going on about the socket connections I managed to re-seat the module and it worked. Socket connection is somewhat dubious.

Thanks all for input!!!


#13

@ All-

Thanks all for your input!!! I have now succesfully updated to 4.2.10 and have successfully deployed using VS2010.


#14

I have exactly the same issue as trapperbob had except after resetting G400 module several times, trimming edge connector (some have complained about contacts misalignment), and having samba and the programmer loaded. I still haven’t been able to get boot loader to correctly function. Shorting PA11 to ground on power up will get an “unknown device” error and will not enumerate to a usb com port. powering up without PA11 jumper device shows up GHI micro framework USB debugging interface.
I m running win 7 64bit w/ vs2010.
Any ideas? or sounds like a bad unit.


#15

@ User_2520 - if USB works by default but not installing COM when going onto SAM-BA mode then your unit is not defective. Try a different USB port, use power pack or powered USB hub.