Main Site Documentation

Device is not connected or not responding


#1

I have a FEZ Cobra II WiFi and drivers installed OK when this was plugged in.
Started up Visual Studio and created a simple project which failed to deploy as I was using SDK 4.3 on VS but this did not match the mainboard.
I used FEZ Config which detected the mainboard and did a Check device for update and carried out a successful firmware update.
However, after this FEZ Config would no longer Ping or check for updates and gives the message ‘Device is not connected or not responding’.
It is connected via USB and detects the mainboard OK and shows the device to be G120_Gadgeteer.
After a failure this board name blanks but reappears a bit later. It could be that the mainboard is resetting because the disappearance and reappearance of the G120_Gadgeteer label is what happens when the reset button is pressed.

I have tried powering the board from a separate PSU but this did not help.

Does anyone have any ideas?

Its odd because it worked OK before the firmware update but after reporting it was successful I have had no joy since.
Is there another way to update firmware as I can’t use FEZ Config because of the error.

Thank you


#2

Did you update the bootloader as well.
So far the boot loader version needs to match the FW version.
You can uüdate the boot loader with fez config as well.
It’s “hidden” in the top left menu.
There is also documentation about loader update in the Support/Documents section.


#3

That’s got it thank you.